My Cloud shuts down my internet router

I have a My Cloud that was connected to my home network with a Wifi Router (Asus). It worked fine for a few months until one day the Wifi Router reset suddenly and couldn’t connect to the internet. At first, I thought it was the wifi router and I changed it to an old one (Dlink) and after a while the same happened. Only time where I was able to get stable internet connection with the wifi router for a significant period of time is when the My Cloud device was disconnected. Then, I stopped using the My Cloud for a while… I recently bought a new wifi router that I used without the My Cloud for three weeks and it worked fine. Yesterday night, I decided to connect the My Cloud and this afternoon I experienced the same issue: The wifi router automatically reset and couldn’t connect to the Internet. I disconnected the My Cloud and reset my Wifi Router and it is working fine again. Has this happened to anyone before? If so, any potential solution? Thanks

Does the router have logs you can check to see why it is restarting? Perhaps the logs will provide some explanation as to what his happening and what causes the router to be reset.

@sipiriaelalo Do you lose your internet connection completely or just to your My Cloud? Who is your ISP? What type of modem do you have? What model is your Asus router? What are the lights showing on your My Cloud, on the back? The more info you provide the more we have to work with.

check your DSN numbers on both the cloud and your router. If one set doesn’t resolve, it may lock up one or the other.

In most cases your internet provider sets it to an internal DSN number that may go down thus you can use Google’s DNS

the IP addresses and as your DNS servers.


add and to the list of DNS servers.

You can also change your DNS numbers on your computers as well so that resolutions of URL are quicker.

Follow the guidelines here for OpenDNS. You can substitute Google’s DNS numbers for OpenDNS.

Be careful on creating Static IP’s on your Cloud. You can change your router’s DHCP to assign Google’s DNS or Open DNS.

good luck. Let us know if this resolve your problem.

Thank you all for your reply. Sorry it took me a while to respond.
Bennor - There is a log and one thing that caugh my attention is that it says “WAN Connection: ISP’s DHCP did not function properly” and it starts doing a bunch of reset instructions. That flow happens multiple times during the time of the Internet connection shut down.

cat0w - I lose my internet completely for all devices, not only the WD My Cloud. My ISP is Comcast and I checked with them the quality of the signal. They even sent a technician a few days ago to optimize the signal. The modem I have is a Netgear CMD31T DOCSIS 3.0 Cable Model and the Asus Router is an RT-AC66U. The My Cloud shows the green light on the back and the yellow light on the front when the problem is happening.

Ralphael - I am not very versed on these network topics, so you will have to talk to me in layman words. In the dashboard of the wireless router, there is an option in the WAN setting for WAN DNS setting. It allows me to either Connect to “DNS Server Automatically”. When I select No, it also gives me the option to add two fields “DNS Server1” & “DNS Server2”. Is that where I should add the OpenDNS IP addresses? What is that supposed to do?

it is best to leave it alone :stuck_out_tongue: I had thought you may have changed the DNS in your cloud when setting a static ip which may be the cause of locking out the internet.

Got it. Both my Wifi Router and the WD My Cloud are with default settings.