My Cloud READ ONLY on Windows 10

#1

I had previously used WD My Cloud on Windows 7. Everything always worked as it should. Enter Windows 10. What a disaster! I can see My Cloud on my network, have access to all files. But I can change or delete NOTHING! Everything is up to date: Windows 10, My Cloud firmware. I have entered my credentials where called for in Control Panel. I have changed the registry. Nothing works!

This is driving me crazy! I would appreciate any help you might offer.
TIA

#2

First, have you accessed the My Cloud Dashboard user interface and ensured the User account you are using to access the My Cloud has Full Access to the Share (I assume the Share is configured as a Private Share) that your trying to access? One of the User permission settings when setting a Share to Private is Read Only access.

Second, you may want to read through the Compilation of Windows 10 Methods, Steps and Solutions thread tacked at the top of this subforum to see if there is anything in there that may affect or solve your issue. Windows 10 has problems in certain instances with the My Cloud, most of those problems are caused by Microsoft Windows 10 operating system and not necessarily the WD MY Cloud device.

#3

Thanks for your reply. I have checked the shares and their permissions. The thing is that the shares I am trying to access are in the “PUBLIC” folder, so anyone who has access to MY CLOUD has access to these videos. There ARE nopermissions, simply because they are public, I guess. That whole area is grayed out.

I did look through the windows !0 steps and solutions and didn’t see anything that applied. I am totally prepared to go back to Windows 7. This is a real pain!

And if and when I find a solution, who is to say the solution will be good a few months from now…with daily Windows Updates…and NO SYSTEM RESTORE!

Pardon my rant. Thanks for your efforts and if you think of anything else, I am still looking.

#4

One thing I have noticed currently is that it IS possible to move files OUT of MC. It is NOT possible to move files INTO MC, nor is it possible to edit the names or locations of those files already there. Makes it fairly useless as a storage device. I keep hoping something will change…

#5

What troubleshooting steps have you done? Have you rebooted both the computer and the My Cloud? Did you recently update the firmware for the My Cloud? If so from what version to what version? If not what firmware version (located on the Dashboard) are you using? If you have mapped a drive have you removed that mapping then remapped?

#6

I updated the firmware yesterday to 04.04.02-105: Core F/W.
I rebooted the computer countless times, also the MC. I reset the MC once.
No mapped drive.
I can still use this drive to watch movies remotely on Apple TV, iPad, whatever.
I checked network settings on Win 10. At this point though, i think the real problem has something to do with settings somewhere on the MC. I can drag and drop/ copy and paste OUT, can do NOTHING into! It’s crazy! Yet all of this stuff is in the PUBLIC folder, so why would read/write settings be limited? Plus the fact that I am admin. The MC is hooked up to Win 10 computer via ethernet cable.

This IS a new computer, fresh install of Windows 10.
When I hooked up the MC, I did just that. I plugged it in. It had been set up initially on Windows 7.

Thanks for your help!

#7

When you say; “The MC is hooked up to Win 10 computer via ethernet cable” does that mean you have the My Cloud directly connected to the computer without having it connected to a router?

Do you have the same problem copying files to other user Shares created through the Dashboard?

Other ways to test and isolate the problem. Do you have another computer or mobile device you can test to see if its the Windows 10 computer or the My Cloud? Have you tried using the WD My Cloud Desktop for Windows software to copy a file (or files) to the My Cloud?

In the past with prior firmware versions people had problems with certain folders being public only access post firmware upgrade.

https://community.wd.com/t/folders-within-public-share-read-only-after-firmware-update/96613

#8

I noticed that I also could not copy a file to the Public folder on my windows 10 laptop. I went downstairs and on my desktop mapped the Public folder and copied a file to it. So I went back to the laptop and disconnected the mapped Public folder. Then I remapped it and was able to copy from the laptop to the Public folder. My Public folder was mapped before the firmware upgrade. It was not mapped on my desktop. So the solution may be as simple as disconnecting and remapping.

RAC

#9

Hallelujah! It is now working! Not quite sure exactly what I did, but it is connected somehow to the Network and permissions within.

First I created a new folder on WDMyCloud on my iPad.
I went back to the desktop, rebooted, could not SEE the new folder created. Access to any of the files on MC has never been a problem. I can see them, watch movies on the iPad from MC. I can even move folders OUT of MC; just can’t move anything in.

Altho my drive was not previously mapped, I thought I would give this a try. Can’t hurt, might help, and rac8006 had given me a new perspective. So I tried to do that, but Windows 10 would not let me. It was not showing me the contents of the drive as it had on Windows 7. (Just a WD logo, which I found strange Now it shows an icon of the files. Photo attached.) It kept telling me I needed to set permissions, so I just set everything to ALL PERMISSIONS GRANTED! (There is something very strange with this network). IT didn’t seem to be accepting that, but suddenly, voilà! I had a “tree” of the files on MC in front of me, they looked like they should (they show up as a tree), and they were accessible. And still are! AND the new folder I made on my iPad shows up!! What more could I ask?!

Thanks so much for sticking with me, Bennor, and thanks also to rac8006!! You guys really made a big difference in my sanity! Bravo!

#10