My Cloud Public File

Is the public file where you would share files? The file that has your name on it is just for you?

The Public Share folder is open to all who can access the My Cloud. One cannot disable the Public Access to the Public Share through the My Cloud Dashboard. Each individual user created Share on the My Cloud can either be set to Public Access or Private Access.

If you have not already done so, you should read through the My Cloud User Manual ( that manual contains much information on how to use the features of the My Cloud.

If you plan on storing media to the Public Share folder for media streaming, it is generally recommend not to do so. More explanation on that recommendation can be found in the following thread.

Sorry, I have to say “baloney” to this comment and the info referred to.

ALL of my media files are stored in Public on My Cloud and anything in there streams all over to my devices in the house and from away, via Internet to me and others. , Music, photos, videos stream to iThings and Kindle tablets. As for video, mp4/m4v files are DLNA compliant video files, but nothing that is not DLNA compliant can stream this way: example: ISO files with a movie on them are NOT video files; they are disk image files of a DVD. Twonky cannot play these files because they are not compliant. It takes accessing the file from a “network share” not a “media server” condition and played by a device like the WDTV. Since the My Cloud can be a server or a share, I stream ISO files (containing movie) from my My Cloud to the WDTV as a shared file all the time to my WDTV to watch on my (non) Smart TV.

Many people do not understand these distinctions, and I have repeated this info more times than I want to in these forums! And, I just did it again. :weary:


deleted again. (darn Discourse platform)

mike27oct, go read that FAQ that CP put together if you haven’t done so already (I assume you have). It explains why putting media in the main Public folder is not the wisest course of action. The other reason not to use the Public share is anything put in there is accessible to all outside of DLNA because there is no way (through the Dashboard) to disable the Public Share folder. While its true that DLNA will access any and all media in a private share if media serving is enable, the files won’t be accessible to anyone using FTP, or a computer/mobile device file manager or WD apps/software/ unless one inputs a username/password.

Yes, Bennor, thanks for commenting. I have looked through CP’s extremely long post. A lot of good info in there, and he also seems like a nice and helpful guy as you and I are around here.

All that “extra” rational and justification is unnecessary for my purposes. My NAS is used internally only for me and family. No one has access but us, and currently I do not share all my media with the rest of the world, I don’t do torrents either, nor do I allow FTP. (Although, there is a drive attached to my router I set up once that way for someone to download from, and then I turned off FTP for drive).

For the media I do share, I have a Pogoplug virtual Cloud where stuff is stored for family members to download (or stream) from if I set up access for them. I really don’t want a bunch of people downloading from my network and sucking down MY bandwidth speed. The PP Cloud is off site and has no affect on my network

So, I and wife are the only ones who can access the DL2100 from home or away. No one is going to break into our network. Not only because they can’t, because of layers of security, but because the creeps have more important servers to break into than mine where they can do their mischief.

My previous experience with this media-storing stuff is with two drives with media on them connected to my WDTV and which are shared drives I also can connect to from home or away. The NAS has lots more HD space, and therefore basically is like a bigger HD I can store files and media on; with the added convenience of being a media share and server for our home. In addition, the NAS is stand-alone and does not have to be connected to anything but the router… We don’t have or need a Smart TV; The WDTV and all the other devices connected to the network, make our TV “smarter” than a Smart TV.

So, I leave my comments above to stand as is, based upon this additional info I have now shared.
So, tell me, am I missing anything here, now? I really would like to know.

Because the sub folders (Share Music, Share Pictures, Share Videos) within the Public Share use spaces in the names one can run into problems since Linux sometimes doesn’t handle spaces in file/folder names well. Especially if the firmware coding is poor, and we’ve unfortunately had ample evidence of occasional poor coding with the Dashboard (and other firmware) files. As that FAQ points out sometimes things can go wrong due to the file/folder name space issue. In the distant past I too have had issues with media put into that Public Share folder that was solved by moving into another folder.

Of course there is also the issue that occurred during one of the recent firmware upgrades where the Public folder became locked and was read only.

If its working for you, great, but to avoid potential issues that might arise due to the space in the name issue, there is no reason for one not to take an extra minute to create separate shares (without spaces in the name) that one can have more control over.

Thanks Pal. although the problems you mention are with the basic My Clouds, (which from reading the forum, I am glad I never had) and I hope these and other issues were squashed by the time they created the DL series. Let’s hope that WD learned something before subsequent upgrades to new models.

If WD learned something from the previous models. They would be able to fix the problems with the old models.


Not if they have the same hardware, which they don’t.

The DL uses v2.x version firmware while the single bay first gen My Cloud devices use v4.x firmware. Different hardware, different firmware with different features and different problems. So while you may not have problems putting files in the public share folder on a DL My Cloud someone might experience problems doing so on the single bay v4.x My Clouds (which some of us have).

The v4.x My Cloud that I use has worked fine for the most part outside of two or three specific issues that don’t affect the overall usage of the My Cloud in the manor I use it, as there are workarounds for those issues.

On a side note, I’ve commented in the past that by now having two sets of firmware (v4.x and now v2.x) for the single bay My Clouds it will cause support/troubleshooting problems, as each firmware may have its own quirks, issues and workarounds.