My Cloud OS5 - Indexing taking forever

So, here’s my findings after installing and testing a Synology DS118 with 4TB (only 1 HDD, but more CPU and RAM than my WD MyCloud Ultra EX2 8TB). Both setups have the same cost, give or take 10 €. I mostly use it as backup for my precious data, stored on an iMac. I’ll try to give an honest comparison here

In terms of initial account setup, I believe both WD and SYN are equally OK, both could do better IMHO. The fluidity, looks and responsiveness of the SYN seem better though.

When it comes to data transfer, actually I saw little improvement. Transferring the 1 TB of pictures, songs & videos from WD to SYN took hooouuurs, at speeds ranging from 7 to 22 MB/s. Both connected to the same Gigabit router. Who’s to blame, hard to say at this point. Also transferring from iMac to SYN, via WiFi, topped at 22 MB/s.
I found out a bit late that on iOS I had to configure the server as SMB instead of AFP, suddenly data transfer went at dazzling speeds of 60-80 MB/s (via Wi-Fi) :crazy_face: . Happy me! But I’m afraid I made the same mistake on WD, and could imagine WD can also take these speeds.

Then comes the setup of the SYN for my “daily life” ; TimeMachine backup, sync music & pictures, mobile photo backup alerts for emails, … Actually, I’m a bit puzzled here, the SYN comes with a mass of applications (packages) and setting options every tech’ would dream of, for a “normal-IT-user-with-decent-knowledge” it’s by times overwhelming, and you get lost in all the screens. Honestly, I found the WD far easier to configure for my use. Too bad WD was slow in response and by times crashing (due to all this indexing non-sense). But clearly, if you like to have control on everything and can spend some time on configuration, SYN will go further for you. And the SYN help pages (just google what you look for) a very well done and extensive, so even newbies can manage.

Indexing to be clear, also SYN requires indexing and thumbnailing, and I wouldn’t call it fast. But faster than WD in my opinion (admitted, I have a faster CPU on SYN). Also SYN makes it more transparent what is being indexed or thumbnailed, and you can easily plan these tasks (during the night for instance). Good point also for SYN, newly added pictures from mobile backups are thumbnailed at upload.

The “little extras” like Plex, media server, photo indexing ; Also here, more processing power, more speed. And more options to configure. I didn’t test this a lot on WD, as it was drowning in indexing, but you see more potential at SYN. I would advise an even stronger SYN than mine (like the DS220play) if this is important to you, for me it’s “nice to have”.

In conclusion, I’m puzzled as I had higher expectations towards SYN, but I wouldn’t go back to WD for the whole fuzz and complications it gave on the simple mission I had for it ; keeping my data safe and easily accessible. The latter failed. A pity, because, at this price (280 €), 2 x 4TB is a real bargain. But I guess you get what you pay for…

Hope this helps the one or other in their quest for a good home-backup-setup. And gives some guidance to WD where to improve:slight_smile: I’m returning mine today :man_shrugging:

Indexing 6TB. 34% done after 17 days (progress of last 8 days: 8%). Running all day. No loud fan noise. Temp is okay. Still annoying.

Preprocessing is useful only, when it is known, that

  1. processing will be needed at all and
  2. processing without preprocessing will be slow, i.e. at least one of the following is true
    2a. intollerable slow processing without preprocessing or
    2b. the estimated total sum of time for preprocessing and resulting processing time will be less than the estimated total sum of processing, when no preprocessing is done.

On my machine a not preprocessed search for a file by a character pattern will check 2M files in about 10 minutes. Combining this with your preprocessing time, means that more than 7k such searches with zero time delay are needed to break even.

I think I understand what you’re saying here. Would have loved to have an option “use the cloud, but don’t preprocess all files, because it takes forever”.

5.11.112 was released today

Still having issues. Now my NAS will not share its data with the os5 website or app. I’ve tried a few steps with tech support. They are not sure what’s wrong. Support said it needs looked at by the developers. This os5 upgrade has been absolutely horrible.

Any updates? I still can’t get into my app or os5 website to see my data.

@SBrown
having installed 5.11.112 on my nas i may report that this release didn’t solve any of my problems!
my drive eventually restarts the indexing process with no reason as my drive was always up and connected.
if indexing is finished (as it was a few times already) the drive keeps to be inresponsive from the web. only thing working is the integration in my local lan network. that shows a lag on fiorst connect and then runs fine

Indexing is horribly broken on OS5, whether intentionally by WD or due to their sheer ineptitude is another story. Do you really need indexing? You don’t need it for access within LAN and Plex uses its own indexing, only WD apps and web make use of indexing as far as I know. If you absolutely need to use WD apps, there’s still time to move back to OS3 before these stupid devs plug that option.

Hello:

This might help to some of you if you unit becomes non-responsive during indexing. , I managed to prevent indexing to freeze by removing from cloud shares certain complex files which I guess were causing trouble to the indexing process (maybe too complex to get the medatada or preview).

I have a single bay My Cloud 2nd generation, and I updated directly to 5.11.112. from 2.xx. last week

With cloud access enabled, the unit became unresponsive after reaching 83% of indexing. No web access, unable to connect to shares (samba/windows), only a extremely slow SSH access was availible.

To get to 83% it took no more than 20 minutes (1TB of data, moslty multimedia), and then freezed. The only way to recover is to phisically reboot or stop restsdh.

With SSH and detailed log enabled, I found that on “wdlog.log” there were some entries referring to files on my shares with message “partial indexing stats with path”. So what I did is to remove (whether deleting, zipping or moving to another share, without cloud access) the last file displayed on that log just before freezing (tail -f /var/log/wdlog.log to live check the log on the terminal).

So everytime the unit became unresponsive, I stopped restsdk (restsdk.sh stop), move or delete the last file shown on the log and restart restsdk and the log tail. Indexing restarted from 0% and then freezed, but with a larger percentage of completion each time. So, after a few iterations the indexing finished in around 40 minutes and cloud status changed to “generating previews” (which I’m currently now, still taking a lot of time but at least the unit is fully responsive).

At the end, In my case there were a few heavy PDFs and some satellite stream captures (.ts with multiple channels or programs inside) that I moved away to make indexing flow.

I tried to turn off cloud access before I came out with this workaround, on that case no indexing issues were shown, as many of you have confirmed.

Hope this helps.

Kind regards,
Juan.

1 Like

Indexing/Generating Previews of 6TB since 42 days. Running all day. No loud fan noise. Temp is okay. Still very annoying. Progress of the first 17 days: 34% - after the update to 5.11.112 there is no % data of the progress anymore. Bravo, WD, problem well handled.

Transcoding of video content can disabled if you are not using Web and Mobile app to watch content that requires transcoding to view. It will save you some “Generating Previews” processing time.
The indexing percentage sign didn’t go away in 5.11.112.

My Cloud OS 5: PR Series Enable and Disable Content Transcoding

Answer ID 30085

image

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Is the option hidden while indexing?

The general problem is your User Experience Design. Give us more information about what is happening and what happened.

  • A notification about “initial indexing is finished”.
  • Or information about how long it can take to generate previews and that I can disable transcoding (it’s not in the settings, but “hidden” inside the cloud tab, if visible at all (in my case)). And that it could take over 100gb of space.
  • Or an information before the update to OS5, which tasks have to be redone and that the interface is still the same non-responsive like in OS3.
    Such things would help reduze frustrations about your software or products.