My Cloud OS 3 app on iOS not possibly joining my My Cloud Mirror device

I have updated the My Cloud iOS app and now it is showing as My Cloud OS 3. My previously My Cloud Mirror device is not displayed any longer and when I try adding it manually, I don’t even find the option to add My Cloud Mirror devices. All I can find is WD drive and My Passport devices. Is it just me that is encountering the issue?

Please note, once you migrate to My Cloud OS 5, you will not be able to use My Cloud OS 3 applications with the My Cloud OS 5 devices, and you will need to configure your device to setup cloud access with My Cloud OS 5.

Thanks! But I haven’t upgraded my device to OS 5…that’s the thing. I only updated the iOS app…

OK, I have solved it. This is what I did:

  1. Deleted iOS app from iPhone and reinstalled it
  2. I logged on to WD My Cloud and got the registered devices, but would not connect (kept getting an error)
  3. Rebooted the My Cloud Mirror, logged on to it through the browser, waited for it to rebuild and opened iOS app again
  4. Configured iOS app all over again and it worked!

Thanks so much for your support!