My cloud no longer boots / white LED permanently

Good Morning all.

I have a problem with my “My Cloud 3TB”. After a desk conversion, I wanted to connect this again. Unfortunately, this does not seem to boot and the white LED lights up permanently. Of course, I have already researched myself and have tried the following solutions.

  • Press the reset button for 3 seconds.
  • Tried the “40 second” reset.
  • Rooter and “My Cloud” disconnected from the mains and reconnected.

Unfortunately, these steps were unsuccessful and I’m really baffled what I should do and of course I am afraid for my data. As I’ve already seen, this issue has had some, but what the ultimate solution was, or maybe “WD” could repair these “My Clouds”, I could not find out in any way.

Therefore, I go now this way and hope that one or the other can help me here.

Thanks and best regards


@spoethig What do you mean by desk conversion? Do you have you My Cloud connected to your router?

1 Like

@cat0w Thanks for your awnser.

Sorry for my english. I meant that I have rebuilt my desk :-). Yes, I have the “MyCloud” connected directly to my router.

I am having the same problem. WD setup will not run as it does not find my drive. A Windows 10 update disabled the SMB 1.0 protocols for security reasons. But, I have turned on Network Discovery in Windows 10 and the drive now is visible on File Manager. But my drive shows a white light, blinks, and turns off when I try to boot it. My ISP has confirmed that the drive has established a link (DHCP) with the network but the boot up does not continue. So, I am beginning to suspect that my security software is blocking the connection. It notifies me that an unsafe connection was attempted. I think that may have to do with the fact that -for years - WD has used pages with an invalid security certificate. I’m hesitant to tell my security suite to accept it.