My Cloud / no files


After using my device for 4-5 years, i had a problem regarding reaching my data in the disc. When I attempt to reach my files in the disc thru my Win10 computer, I cannot see any files; the explorer says: “the folder is empty”. The disc also seems to be empty when I check it from the dashboard

I am sure I have many photos, videos, etc. in my disc. Can you please help me with that; how can I see my files?

@Kerusu What troubleshooting steps have you taken, if any? Have you rebooted the device? Have you tried a four second reset? Have you clicked on Diagnostics to see what is showing for the Caution?

Have you looked at the User Manual for your generation of My Cloud?

Thanks for your reply. I performed quick and full diagnostic tests. The quick test passed but the full one failed. Following are the notifications I got in dashboard:

I have rebooted the device, applied 4 and 40 second resets but none of them helped.

@Kerusu My next suggestion would be to shut down your device, wait a few hours while it cools down and then restart it. If you have the same problem, then open the Dashboard and click on the ? icon and send your information to Support.


What is the specific error/warning that the Diagnostics indicates on the Home screen?

Some options. Enable SSH within the My Cloud Dashboard and use an SSH client (Putty, WinSCP, etc) to access the My Cloud using SSH. From there you can see if the user data is still there in the Shares. ON a first gen single bay v4.x firmware My Cloud the user Shares are located at: /DataVolume/shares when using SSH.

Sometimes if a partition fails to mount which leads to Diagnostic errors one can try to perform a System Only reset via the My Cloud Dashboard > Settings > Utilities > System Factory Restore > System Only. This generally resets the My Cloud back to default settings and shouldn’t affect any user data. this assumes the user data partition hasn’t already been damaged/erased.

Thanks for the response. The problem still continues after restarting, 4-sec & 40-sec resets. I have also tried consulting the WD support but they responsed that I have a smart disc failure and there is nothing to do since the warranty of my disc expired. Actually all I requested was to reach & save my data in my dics, I had not requested a device renewal…

Thanks for your reply. The warning on the dashboard says “the data volume 1 on the drive is not accessible. contact WD support”.

I tried the system restore but it did not work.

I had succeeded enabling SSH and checking the disc via putty but am not able to do that now (still working on it). If I can, I will check my data by using putty, filezilla.

One interesting is that the dashboard is being opened with the following screen:

Does it mean anything?

I managed to connect to my disc using putty. I checked my disc using filezilla but cannot see anything under the folder /home/root.

If using SSH and a command line window terminal you may need to perform a cd .. to move up to the root level directory from the home directory that normally loads when one initially logs in using SSH.

Edit to add: Just tried it in FileZilla on my first Gen and one can move up a level so they are in the top level root location, and not in the home or root subfolder/directory. From the top root level I can access the shares on my first gen by going to: /DataVolume/shares

I used putty as command window and reached the root directory of my disc. But, when I type “ls” in order to see the files in the root directory I can only see some system files (please see the picture below):

The same files/folders are also seen in filezilla.

Most of those are not files, their directories. See that directory named “shares”? Try accessing that (cd shares) and see if it contains the user Shares.

Here is an example from a first gen My Cloud. It shows one logging in, then navigating to the root level, then accessing the shares directory. The second gen may be slightly different at the top root level. In the shares directory are four shares. One Share I have redacted (its a User Share) in red, the rest are default My Cloud Shares.


Thank you very much. I am now able to see my files in “mnt” folder. Using filezilla, I copied them all to my local disk over the night. The copying has now been completed and I am able to save my files.

Now I will try to reset my WD disc to factory settings in order to use it again. Do you have any other suggestions to solve the problem with the device?

No further suggestions. Hopefully a system factory restore will reset the device and fix the error.