My Cloud multiple bugs in firmware

I am using My Cloud 2TB since 6 months now. My Cloud firmware is riddled with many bugs including some trivial bugs which should have been fixed had there been proper software testing. I am listing few bugs below:

  1. DATE TIME

The date time manual config UI under Settings is buggy. If I try to manually set date after disabling the NTP, no matter what date I pick from the calender, when I click Save button the date of previous day is selected. example if I select 9th feb and click Save then 8th feb is updated to the system.

  1. NOTIFICATION DATE TIME

Notification in the UI always shows wrong date time. I just updated firmware today and its showing notification of firmware updated on ‘Friday, December 12, 2014 12:22:06 PM’!

Untitled2.png

  1. USB DRIVE PARTITON CORRUPTION

I was using WD My Book 1TB attached to the USB for keeping backups as its convinient to copy files over network. Its the 4th time that when I ‘safely ejected’ the drive from My Cloud that the entire partition on the My Book drive was unreadable on my laptop.

I did testing on this multiple times by attaching the drive and then removing it ‘safely’ and it worked properly. But when the drive is attached continously for many weeks and when its ‘safely ejected’, it gets unreadable. I have a UPS power backup for all my devices so there is no power failure reason.

Earlier, I dismissed it as one of issue but its now 4th time that entire backup on My Book 1TB vanished. Even if one carelessly uses USB on laptop by not safely removing it from windows, it affects only the data that was in cache. While with My Cloud even after removing the drive “safely” from the web UI, the entire partition is corrupt.

WD must do some rigorous testing of the firmware. Many peoply rely on these devices and may not have data backups. Its really disappointing to see such trivial issues (mentioned above) in the product.

Hello Shreyas, welcome to the WD Community. Thanks for sharing your feedback. We have passed this along to support. 

1 Like

Thanks for the response. I don’t need support on the issues as they clearly are bugs. This should be instead passed to the firmware development team or the testing team.

For your question #1 what time zone do you have set under Settings>General>Language & Clock>Time Zone?

For question #2 what is showing under Settings>Firmware for Last Update?

Sorry, I can’t help with #3, I don’t have anything attached to my My Cloud.

Posted by,
cat0w (USA)

could you also tell them to fix the check for firmware updates at 3 a.m.? even if I disable the autoupdate, my cloud checks for this at 3 a.m., and thats why it wakes up every day at this time.

 Issue 2

I note that the reported date is very close to the release date of the latest firmware, which was announced 17-dec-2014, but contains a .deb file dated 11-dec-2014.  It wouldn’t surprise me if this .deb name is wrong, and the actual build date is 12-dec-2014…

So I’m guessing that the reported firmware update date is the build date of the image, not the date when the update was performed.

I’d need to check my machine to see what date it reports, but I might imagine a situation where the local time doesn’t ‘make sense’, so the timestamp of the build is used instead; for instance, if the local time is earlier than the build date.  Admittedly, that sort of check would seem out of character for WD, considering the lack of basic checks in other areas of the firmware…

[edit]

Just checked, and, of course, the screen shot you posted is of the update process.  And I’m not going to do that just out of interest…

The other place to check is Settings/Firmware/Available Updates, which shows the last update time.  In my case, it’s the time it was performed, not the build date.

I have UTC+0530 set. I tried even with just UTC and still had the same bug, in fact with just UTC the date would set to 2 days prior (if I set to 13 Feb with UTC time zone and click save, date would be set to 11 Feb).

For the second bug, check image below. I have seen notifications that show date 1 day in future too (i dont have it to take screenshot but, if notification occurs today then it shows tomorrows date in the notification)

Untitled.png

could we make this a sticky post and collect the bugs here…?