My Cloud Mirror Gen2 Plex Error


i have problems with my new My Colud Gen2 6TB.

As I installed the App via the stocklibrary, after a few minutes I cannot reach the Plex Server. Doesnt matter via cick on the Plex config button or reach via device. I tried this many times, but if I turning off the App an turning on, I can reach it max 10 minutes.

Are there any known issue reagarding this problem? 


Welcome to the Community.

How are you trying to access the app? And which devices are involved?

Im having the same problem. I have a My Cloud Mirror Gen2 8TB. I loose access to the plex server a few minutes in. The plex app was installed via the stocklibrary and I access it via the Configure button. I’m then redirected to another page where the Plex Server Interface loads. I only get so far before I get a message that says “WDMyCloud Went Away”. If I try and refresh the page or access it again using the Configure button, the page times out. The only way I can access it again is to switch the server off and on again. A few minutes in it happens all over again.

Another thing I encountered is that I am unable to install the latest version of Plex Server. The stocklibrary version is 091211.1406 and when I am able to get into the server, I get a message that says there is a newer version available. When I click the message, it takes me to where I can download the latest version for WD My Cloud Mirror. The file that downloads is WDMyCloudMirror_plexmediaserver_091213.1464-4ccd2ca.bin. I tried installing it via the stocklibrary by clicking where it says “To install an app manually, click here”. A message appears that says “Updating…” but after a bit, I get error message that says “Failed to install app. Please check the network connection and try again.” I’ve attempted this method both with the Plex Server on and off without success.

Hi, what version of the firmware are you using on the NAS? Have you tried a reset?

I’m on version 2.10.301. I believe that’s the latest. By reset do you mean a System Only Restore? That wont remove my content, will it?

The system only will  not delete any information on the drive however all the settings that you previously performed will need to be done again. Howerver I was talking about the reset button that should be in the back of the unit. 

Okay. Will using the reset button also preserve my data? Also, how should I use the reset button? Should I hold it down with while the device is powerd on? Or while the device is off, power on, then release? Thank you for your help by the way :slight_smile:

1 Like

Same problem. Is this issue solved?

Hey, it seems the Plex Team is working on a new package for Gen2:


I am having the same issue. Having the same issue with the new package from Plex Team.