My Cloud Mirror Gen 2 Microsoft Edge-Browser /Firefox with NoScript

I bought a My Cloud Mirror Gen. 2

I have two problems / questions

  1. I cant acces the MCM with Firefox and active No-Script. The device can not be “located”. When NoScript is disabled ther is no problem. I read that other have the same problem. Is there a solution to acces the MCM with NoScript active?

  2. I have a Smartphone with windows mobile 10. I read the WD2go App is not functional with Mobile 10 and/or MyCloud OS 3. I tried it and cant use it With the Edge-Browser i get no acces, cause the brouwser is not supported yet. In Windows 10 you can change to “IE-Modus”. But there ist no way to do this with the mobile version. Is there a way to gain remote access to the cloud with a windows smartphone?


  1. I don’t use either (I use Chrome with a few similar add-ons, but not NoScript) but as a general question is there any way to exclude websites in NoScript? If so can you do such an exclusion with the MCM’s web address?

  2. I access my Gen1 MCM from my Windows Mobile (8.1) via WebDAV (using WebDAV Nav). You would need to enable that on your MCM to get such access though. You are correct that there is no functional WD app under WP. I don’t access the dashboard from that device, but you probably could do via IE if you so desired.

thanks for the answer.

  1. Yes i can allow script loading for a specific website. But to allow scripts for and wd2go is not enough. After experimenting this morning with the settings i found out that the ABE (Application Boundaries Enforcer) seems to blocking some cross-site-scripting (?). After deactivating this in the settings i have acces to my device.

    Now i must only find a way to allow mycloud to load all “stuff” with ABE allowed

WebDAV is a good idea. I have activated WebDAV in the MCM. But can you explain me what i need to do to get acces with the app? How can i found about my username and passwort. the normal mycloud name and passwort is wrong.

I tried ist with this cause i also use a fritzbox. but i cant find a way to get my user-id and passwort.

Have a look at this page where someone already wrote some instructions on setting up WebDAV fully (I was going to do one myself, then found that so didn’t bother repeating it).

Basically you need to forward the WebDAV ports on your router to the MCM, and then from the wider internet access your home network via its public IP address. Depending on your ISP, this may be a static or a dynamic address, but if it’s dynamic you can make use of a service like or many others (just Google “free dynamic dns”) to give you a fixed URL which resolves to your router’s public IP address even if it changes.

For the scripting stuff it’s one that’s going to be quite specific to your set-up, so what you’re doing by trial and experiment is the best way to go.

I set the ports and use et the moment my dynamic ip. But the authentication fails.

no matter if i try to acces the public folder or a folder i created. I´m not authorized. Is tried the login data froim my cloud. but that seems to be wrong.

The guides refer to a deviceuserid and authcode. Do you know where i can find this?

Ok. I am to stupid. :wink:

Now i get acces to the Public folder (I mistyped the adress). Yet i only need a way to get the userId and password :smile: .

They are the user name and password for the user accounts on your MCM.

Thank a lot,

it´s running. :+1: on PC and Smartphone. Thanks for the help :slight_smile: