My cloud Mirror Gen 2 dreaded FF:FF:FF:FF:FF:FF

I haven’t used my My Cloud Mirror for maybe 2 years, in which time I have all new routers and networks. When I put the Mirror on the network, I cannot reach it. I do see it from a Mac on the same network when typing arp -a into Terminal, but the Mac address is listed as FF:FF:FF:FF:FF:FF and ip address is 192.168.0.255. I don’t recall if I had once assigned a fixed ip address to the mirror, but it is possible.

Based on some research I’ve tried both 4 second and 40 second resets. All lights are blue but cannot connect over the network.

I then connected by Ethernet directly to the Mac Pro. Same issue with Mac address and ip address. I can see it listed in the finder as a shared device but cannot access it.

I don’t care about info on the device so I’m happy to reset the whole thing, just hoping I can get it working again. Can anyone lead me to specific recommendations on how to fix this? Thanks.

See the dedicated subforum for the My Cloud Mirror where users more familiar with that device may be able to assist.

https://community.wd.com/c/personal-cloud-storage/wd-my-cloud-mirror/110

Thanks, I tried finding a subforum but missed it. I’ve posted there, and will try to figure out how to close discussion here.