My Cloud Mirror 2° Gen, stop working and HD not recognized

Hi Guys,

Hope some of you can help me with my problems with the My Cloud Mirror gen 2°.

About a month ago it stopped working, as if there was no power.
I tried to change the power supply, but nothing changes.

Then I contacted support who simply told me that the product is no longer under warranty and if it does not turn on they cannot do anything.

Then either tried to extract the two 4tb mode disks (RAID1 for maximum security), inserted in a 3.5-inch hard disk case and connected to the MAc, but the Mac says it cannot read the hard disks, with both the same answer.

My questions are:

How do I access hard drives?

Is it possible that both hard drives have been irreparably damaged? RAID 1 mode should be used to ensure maximum data safety security!

If I purchased another My Cloud, would it automatically recognize the hard drives and could I access the data or should I initialize them as with NAS from other producers?

Obviously on these hard drives I have all the most important datas of my life.

Thanks to everyone who will take the time to answer these questions


Have the same problem after powerloss. tried already reset disassemble disks and so on - nothing ! really ■■■■ reliability…

1 Like

Thanks for your answer,

o you think that is a good idea to try to put thr same hard drives in a new My Cloud Mirror just to acces the data?

Don’t give up!