My Cloud is visible but I can't go in and Dashboard says My Cloud is offline

Hi there, Super new here and tried to find my problem on the community but didn’t find others with the problem or didn’t understand what problems others were facing hence a new topic post.

I can see My Cloud drive on my macOS Catalina and my Finder shows I am connected with my username, but when I click into a particular folder inside My Cloud, I get a prompt saying “The operation can’t be completed because the original item for “Folder” can’t be found.”

I cannot update the firmware via the web UI because My Cloud is “Offline” but when I use the Command+K prompt, I can open a folder on My Cloud. In Terminal, I can also see My Cloud use the arp -a command prompt.

I did connect My Cloud to a new router so is this why My Cloud isn’t detected?

Thanks for viewing and responding.

If you log in to your new router, can you see it on the client list? Did you reboot both MyCloud and Mac after installing new router? Have you tried to connect to MyCloud using IP address?