My Cloud is not showing up on the network

#25

I resolved my my cloud not showing in my network discovery by unplugging and plugging back in my cloud on different LAN port on the back of my router which pretty much resolved the problem my network discovery software found my cloud device under network search.

#26

It happened the same to me:  I solved as suggested from the app, connecting using my email and password of the WD account.

#27

I have had this problem on and off ever since I installed the system. It works for a while and then stops.

However, I am able to access MyCloud via file explorer on my laptop but not on my main PC.

I’ve not managed to fix the problem but I have managed to isolate it.  If I reboot the pc and select “safe mode with networking”, everything works as normal.  I have tried using MSCONFIG to disable all drivers and statrtup items but without success.  So, it seems that Windows is loading something that is preventing from File Explorer being able to display the drive.  

Hope this helps and perhaps someone with more technical know-how than me can identify the problem.

Glen

#28

Progress: 

I restored a backup when I only had basic Windows, graphic drivers etc installed and it found the network as it should.  I have also printed out all the network adapter settings from System Configuration.  Will not try a later backup version and see what happens.

If it fails to recognise the network then I shall print out the new adapter settings and compare the two. That should poing me in the right direction.

Will keep you posted.

Glen

#29

No difference in adapter printout, so it MUST be something that has been installed that is preventing Windows from displaying the network infrastructure.

I am not going to uninstall every piece of software using Revo Uninstaller which should also remove all the registry clutter etc.

tbc

#30

This may already been mentioned.  But for a device to be seen on the network it must be

in the sam workgroup as the PC.  To check your PC workgroup. go to the start menu and

right click on computer then click on properties.  The workgroup will be displayed.

RAC

#31

Cracked it!!

Uninstalled programs one by one and after I’d uninstalled BitDefender, it now works perfectly; ergo, something in the “protection” is preventing the network architecture from being correctly displayed.

All I have to do now is find out how to set up BD so that it allows the network adapter to “talk” to Windows correctly.

I would assume that many of the other problems experienced on this thread have something to do with security systems installed, whether it be Windows Firewell or third party software.

Glad it’s all over now.

Glen

#32

With BitDefender and other security programs they may be limiting network access, even local network access, by how one configures the Firewall settings.

For BitDefender the following setting changes may help that was taken from this thread:

Open the Bitdefender program > Protection > click on Firewall > make sure the Firewall is turned ON (the blue check-mark from top-right)

 

Go to the Adapters tab > at “Network Type” select “Home/Office” > at “Stealth Mode” select “Off” > at “Generic” select “Yes”

 

Now please go back (click on the “back” arrow in the upper left part of the window ) > Intrusions Detection > turn off Intrusion Detection System

 

Restart the computer.


For Windows 7 and possibly 8, 8.1 and 10 users if they change their “Network Location” to “Public network” they may be unable to access the WD My Cloud and other devices on their local Network. Using “Home network” or “Work network” should allow the WD My Cloud to be seen and accessed. It comes down to how Network Discovery is set on Windows. If disabled or turned off local devices are not discovered.

#33

I had this issue. All I did was set SMB to Type 1 from Type 2. Then it showed up fine in both Windows 8 and now Windows 10.

#34

Is there any fix for this if you’re running viper? I’m on Windows 8 and having the same problem. Since others are having an issue with their firewall, I assume that’s my problem as well.

#35

 the same problem, it worked fine the first day but now it is not able to connect to my WD my cloud. what should i do?

#36

I was also having the same problem, thats why I googled for a solution and found this discussion.

My problem started when I dragged a folder to the My Cloud and all of a sudden the network drive vanished. I searched the net for soultion with no success. Someone said his problem was resolved when he changed around the network cable on the router. I tried that - no success. I gave up and decided to scanned my receipts using my printer connected via the network. I failed to scan - scanner error. Then it hit me that 2 devices connected to the network were failing something must be wrong with my network. Then I disconnected network cable from my wife’s laptop (I hope I won’t do that if she were hooked to a life machine! just cable humor, no need to lock me up!) which I was using to copy files and switched to wireless since I no longer needed the cable to copy files to a device I could no longer see. Soon as I did that, and went to my laptop. I noticed that I could no longer see my wife’s laptop from my laptop network section. That was it, my network was the problem.

Here is what I did. I waited for everyone to go to sleep, since I dare not disturb their online life:

  1. I switched off the router

  2. Pressed the reset button on the modem…waited for all lights to be solid

  3. Switched on my router

et voila! Everything was now visible, even my mother-in-law’s laptop! I looked at my printer and it said, IP Address changed. I pressed ok. I could scan, I could back up to My Cloud as well. The world is at peace once again! I did all this as a “thief in the night”.

Try it! Hope it helps at least one person.

#37

I got a new My Cloud Mirror Drive and right out of the box it won’t network. Very disappointing!!!
Have spent over 1 hour on the phone with WD customer support and still not working properly!

Anyone have any ideas?

I think I’m going back to the store tomorrow to return this thing and look at other brands of network drives.

#38

Yes, please provide more information. What steps have you tried? What OS are you using? Have you read the following thread if using Windows 10?

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#39

I had the same problem and now it’s solved - hope my answer is helpful.
I’m a user of Windows 7.

Problem:
I downloaded the set up file and started the installation.
During the process the device couldn’t find my network. It just kept asking me to rescan.

Solution:
Open a new web page and type in http://wdmycloud/setup
They will do exactly the same thing online as the installation with the application file you downloaded.
I found my network and finished the setup process.

Hope it helps.

#40

Very helpful. Just to clarify: Go to “Map Network Drive”, then in “Folder” type the IP Address and vuala! It pops right up. Just as a note I completed this step AFTER I created a WD Account, downloaded and set-up “WD My Cloud” Desktop App in September of 2016.

#41

I’m going out of my mind at this problem!

I’m trying to setup the My Cloud desktop item and cannot find the network device despite having both the My Cloud on with solid blue light and my router is on and operational. Both are connected via ethernet cable.

Very strange as I have managed to set it up online using the absolutely rubbish card (no user manual) using the my cloud.com/setup site. I can access the dashboard fine online, but cannot see it on my Finder nor can I see the device or setup the desktop icon on my Mac.

Someone please explain what the heck is going on as I’ve been trying to get it working for weeks!!

#42

I’ve experienced this problem, for weeks! Time Machine cannot find WDMyCloud. I’ve obtained support from WD and Apple. TM would do one backup but fail on subsequent backups. The bottom line, for my computer and my configuration, turned out to be simply shutting down and then restarting the system. All the other stuff like recycling the router, reseting the Mycloud, entering various commands through Terminal and then restarting the computer were not needed. Restarting the computer eliminated the error, at least so far.

#43

I know how to fix it now.

  1. Install the Sync and Access software, even it says can not find device.
  2. Go to http://wdmycloud/UI/, and update the firmware.
  3. After you updated the firmware, your Sync application is able to detect the device automatically.

Done!

#44

I had this problem too . you can update your router firmware. worked for me.