My Cloud is Connected but not "running"

My MY CLOUD is connected to my AT&T U-Verse router via an ethernet switch/hub. The green lights are illuminated (blinking). However, the front blue LED light is no longer on. I used to be able to access the MY CLOUD wirelessly, but since the light went out, I could not connect to it. I tried to directly connect it to my computer via USB cable, which worked with my PC (and was able to get it to work wirelessly via my iPad) for a short time. Now, I tried to connect my iMac via USB and it is not working again (same as wirelessly). I cannot even get to my dashboard because it cannot connect to the MY CLOUD device. I can feel the device and it feels like its running. Could it be a switch/hub problem? I have no idea. I tried a 4 sec reset, which did not work. I’m desperate. Please advise.

@mrabs16 Do you know if you have a first or second generation My Cloud? If both lights on the rear were working as they should then you had a connection. The blue LED on first generation My Clouds will burn out and not be illuminated, however, this does not mean the My Cloud is not working. My front blue LED on my 1st generation has been burned out for several months now.

Is your switch/hub connected to your router. If yes, what does that connection show?

@cat0w I think I have a first generation (need to check). The blue LED light is very faint. In fact, last week, after unplugging/replugging the power back in the LED light (white) would go on before going off. Now, that doesn’t even illuminate. Both green lights on the rear are working.
Yes, my switch/hub is connected to the router and the MyCloud is connected to the switch/hub. There is no light or indicator on my simple switch/hub. Could the switch/hub be bad? Just curious since the connection is made to the MyCloud as demonstrated by the green lights on.
Thanks.

@mrabs16 Before making any changes or trying new equipment you may want to check out these discussions about the AT&T U-Verse Router.

1 Like

Sometimes the front LED on the single bay/single drive My Cloud may have it’s blue color “burn out” and stop functioning.

Can you access the My Cloud via it’s IP address?
Is the ATT router issuing an IP address to the My Cloud? Check the router’s administration page.
Is the separate network switch turned on/being powered? Most network switches have some sort of LED lights to indicate it is on and there is network traffic on the port.

The My Cloud USB port does not support being connected directly to a computer’s USB port. The My Cloud USB port is generally only for connecting an external USB hard drive. One can directly connect the My Cloud network/Ethernet port to a computer’s network/Ethernet port and test connectivity that way.

Some have reported weird My Cloud issues that were due to a failing My Cloud power adapter.

1 Like