My Cloud in File Explorer Windows 10

#1

I have a new PC running Windows 10. I did a full Factory System Restore on My Cloud. At the end it prompted me to install the software on my PC. All done OK. After hours of messing about I have finally managed to get Windows Backup to work. And I can restore a file from that Backup. All good so far (I don’t want to install and use WD SmartWare for my Bckups).
But in Windows 10 File Explorer I would like the My Cloud (and under that all my Shares) to automaticalyl appear under Network when I click Network in File Explorer. I read through the Forum and I can see about pressing Win+R and then typing \nas-name\ and that works OK. My Cloud appears and I can then copy files to and from a Share. But when I reboot my PC it is forgotten. Can I get My Cloud to appear automaticaly under Network wothout doing Win+R and then typing \nas-name\ each time?
Thanks

#2

See tacked thread at the top of this subforum…

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#3

Yes. Select [Computer] on the command line (Windows Explorer), select [Add a network location] -or- select [Map a network drive] and follow instructions. These are persistent objects and will be there when you reboot.

Paul

1 Like
#4

Thanks to Bennor and Morden2004 for their replies:

  1. Bennor - Yes, I had seen that post and read through it. But, to be frank, a lot of it I couldn’t understand. I do wish WD made it clear on the packaging that some considerable computer knowledge is required to get it all going. It is not plug ‘n’ play. I had understood to make my network private (done) and my items discoverable (done). I had hoped that I was now so close it would be a simple task to just finally get over the finishing line.
    The other thing that scares me witless is the law of unexpected consequencies. I click here, then there, and before I realize what has happened I’m in a worse state then when I started. I originaly purchased My Cloud to go with my old Windows Vista PC (now deceased). I must have spent hours (if not days) of my life getting it to work. After which I touched nothing. Unfortunately that PC died and now I start all again with Windows 10.

Morden2004 - Thanks. I started off with great hopes as this seemed so straightforward. I did File Exploreer. Selected This PC. Then selected the Compter tab. Then Map Network Drive. But browsing doesn’t show My Cloud. And Win+R doesn’t bring it up in the window when I Browse. Have I missed something basic here do you think?
Many Thanks

#5

I do wish WD made it clear on the packaging that some considerable computer knowledge is required to get it all going. It is not plug ‘n’ play.

It’s true that it can be difficult, but it’s also true that it can sometimes be very straightforward.

I think part of the problem is WD’s attempt to make setup automated, using the setup program, and various utilities you can load onto the PC. The problem is that, if something goes wrong with this process, the naive user is left high and dry.

Having learned how to drive the thing via the Dashboard, when I bought a second unit, I had it setup and running as I wanted it within 10 minutes of opening the box. It’s actually pretty simple, just that the manual is pretty poor at guiding the user through setup, and adding features incrementally, as required/as the user learns more about the device. It is, though, very worth reading, especially after the poor introductory setup sections; the sections describing how to manage the device using the Dashboard are pretty good, but could still be improved.

With some simple additions to the Dashboard, and a better user manual, the device could be made very simple to manage.

The fact that Apple and Microsoft have rolled out new operating systems that break previously working installations is poor; there’s a strong argument that it is their fault, and not WD’s, but it’s also possible that WD haven’t implemented some protocols correctly, and maybe the new OS adheres more strictly to standards, and thus the MC no longer works. Both sides of the interface ought to be working together to resolve it; whether they are is another matter. Apple certainly have a reputation for being rather uncooperative with third party manufacturers…

#6

No, you were on the right track. But since the Windows 10 {bug} won’t show you your NAS which you need to select it, you can enter it in directly when you Map that drive.

Assuming you didn’t rename the device when you did the install, at the prompt for [Folder name] (where the [Browse] button is) enter “\WDMyCloud\Public” (skip the “” marks) and hit enter. Repeat for any other shares you created.

Paul

1 Like
#7

Thanks Morden2004 - You are a star. Thanks for all your help. My Cloud now working with Windows 10. I know this will be obvious for all techies, but just in case some computer illeterate like me is browsing the forum with the same problem, there needs to be two back slashes before the WDMYCloud.
I really do like the product once it is working, but it can take some time to get there and I don’t think I would have made it through to the end without your help.
Thanks

#8

You are most welcome. I’m glad you have it working.

Paul