My Cloud Home no longer appears on my desktop after software update

I use my My Cloud Home daily as a back-up and large file storage.

Over the last two weeks, I have not been able to “see” the My Cloud Home on my desktop. This occurred after the My Cloud Home software updated to 7.12.0-164. The My Discovery App has shown the device as offline or online with a generic NAS icon and I can not reach it from my Finder application.

I have reloaded the My Discovery App, I have done a clean uninstall using both the uninstaller app and a third-party program, and I have even gone in manually to my Library to attempt to make sure there are no additional files that might be lingering. The results are always the same. I am able to reach the device from a browser and my iPhone but I can’t reach it from my desktop. I have rebooted the MyCloud Home from the browser which caused it to go into an endless reboot cycle that I could only stop by removing power and doing a cold startup.

WD support has opened a ticket for this and has asked numerous “stupid-user-error” questions. After all of this, the support rep has concluded the drive is bad. It’s clear to me there is something wrong with the interface with my Mac either through the WD Discovery App settings or some error in the My Cloud Home software update 7.12.0-164. I am very frustrated that I can’t get them to run the software update again since I have never had control of how software is updated on this device.

Has anyone else had a problem like this?

1 Like

Very similar problems started for me a couple weeks ago but with my Acronis True Image backup program no longer being to see the My Cloud Home drive. Acronis support blames WD and when I contacted WD support, I got sluffed off with them blaming “Acronis”. We get stuck with no help for one of the most important tasks we need - the ability to reliably back up our work.

I have similar problem; MyCloudHome not showing in Explorer, and Acronis no longer able to back-up to drive. Also can’t log into drive online; reports unit offline. WD Discovery also can’t connect (re-installed to check most up-to-date). Meanwhile, my older MyBookLive drive continues to function perfectly on same network, with Acronis working fine, and MyBookLive being visible in Explorer. I did notice an email from WD saying my MyCloudHome was about to run out of space around the same day Acronis was last able to back-up to the MyCloudHome, but surely that wouldn’t cause the drive to become inaccessible?

I finally got Acronis to see the drive by using it’s IP address instead of its name.
Also, if there’s not enough room left in the MCH, it won’t perform the backup. To avoid that, under advanced and / or options set it to save no more than “x” backups and it will delete the oldest to reclaim enough space.

Did you figure out an answer? I am having almost the exact same issue. I have been on the chat with WD twice and they have not been able to assist me. I am going to try a USB cord tomorrow and plug to a laptop. I have lost four days of work dealing with this issue.

As I said above, you have to use the device’s IP address. You can find this by logging into your router and checking listed devices.

I have tried that. It does not show up in terminal at all.

I have finally got My Cloud Home running again after a lot of hassle. The WD instructions do work but you have to follow them to the letter with some inspired guesswork thrown in. I eventually got rid of all WD related files which WD does tell you to do but it doesn’t say where they and and using Terminal did not help. I found them by searching applications in Finder and deleting everything that had WD in the name. At that point the WD instructions worked and my system is working perfectly.

I still need help!! I am so frustrated. Please tell me what you did.

Hi Dhb

I did as I said in the first comment. I used Finder to search for any file that mentioned WD and deleted it. Once I had deleted everything I restarted the machine I searched again on finder for WD related files and I continued doing that cycle of search and delete and restart until WD didn’t show. I did one final restart then used the WD link to OS 11 and downloaded the files. From then on the WD guide worked and My WD Home now works.

For me, once I used the IP address of my My Cloud Home device instead of its name (find by logging into router). It worked.


I have tried the device’s IP address and that doesn’t work. WD has escalated this to their level 2 and they have some log files to analyze but I’ve heard nothing back from them.

I guess I lucked out. Wish I had more ideas and a better memory.