My cloud home - desperately seeking frustration - ftp or os?

The only thing you´ll find worse than the MyCloud Home in the entire wd community are smug gits who can´t wait to pounce with “well, if you´d done your research you´d know it wasn´t designed as a nas drive, wah, wah, i haven´t got a girlfriend”.

Just because WD can fallback on detailed specs that weren´t reflected in the product marketing or broad acceptance of what an ethernet connected hard drive can do, doesn´t make it right. Who buys a car thinking it might not have any forward gears? If it says car in the showroom you expect it to do what a car does, without having to sit on the showroom floor and read the entire service manual to find out if some douche of a designer thought it would be whack to produce a backwards only car for todays modern app-centric consumer.

I don´t know if this car analogy is helping, but its written now, so it can.t be changed. I can´t realise i might have made a mistake and go back - can I WD? That´s not possible is it?

When I bought mine WD weren´t even showing how to map a drive in windows, i totally left the app ■■■■ interface and just used it from windows ever since, but with them choosing to end support for my other mycloud, i want to be able to use the home for secure content, and to ftp files in bulk.

And even if you fall in the school of people who think its ok to be so ■■■■, that doesnt let wd off the hook for the things it is meant to do.

I might have thought that in 6 years the software would have improved a bit, but it all came flooding back as the crappiest most annoying amatuerish suite of utilities i have ever used, and that goes back to win 95.
The backup doesnt recognise any physical drive or cloud service apart from dropbox, though discovery shows other physical drives and i have the two most common clouds. OK, not so bad you might think, you cn attach the ones it doesn´t recognise, right? No sir, not this pile of pointlessness. No options. You want to back up, you have to use the only backup option it finds, even if it is the only one you don´t have.
The utilities can´t run any of its 3 jobs, and the settings cant do its sole contribution to a tab of its own, turning a light on or off. You can click on it. Knock yourself out, but it doesn´t do anything.
The only remaining option is to erase entire drive, Somehow i bet that one works.
It does display device info though, except it doesn´t . the only thing i want to know is the firmware - but that field is blank. It is a very limited utility suite that would barely justify its own menu let alone an entire app, but it cannot do a single one of even that small set of stuff.
Never mind, better luck with security perhaps? except no, that one of the suite can´t even be bothered to get involved, simply refusing to recognise i have a drive at all.
And worth pointing out that these three, backup, utility and security are all sub-apps, you can´t install them without installing the discovery container, and the discovery container gets all the information they can´t, but it has no tools to actually do anything.
And the desktop app, that´s new, that must have come in after i´d given up, obviously a reluctant concession. It is as if it was specifically designed to do absolutely nothing. It just lets you glimpse at your file structure, like some slutty little tech tease, showing you what it could so easily have been.

It took me an hour to have installed and tried the various tools, rebooted, tried again, etc etc, all the time it dawning on me again what an utter piece of ■■■■ it is. I have no way of telling what firmware it has, nor any way given by wd other than using the automatic update that isn´t working. I have no way of scheduling sleep or reboots, outrageous in a piece of kit, and there is nothing in the awful “lets get creative guys” web interface that shows it up for what it really is, a device for iphone users. no settings options, no hardware status or firmware information. And across all of this one more thing shouts out, where is the security?

Absolute joke of a product.

If anyone has found a way of connecting by ftp (i dont think ssh is an option at all) i would really appreciate the help. For anybody who comes across this hoping for same. An inadequate but better than nothing workaround is to map your windows drive and then you can get to it via filezilla which will still hable stuff a lot quicker even if you have to upload it to download it instead of jusdt moving it.

Also if anyone can throw any light on what the os actually is?

There is nothing wrong with wd creating a product aimed at a different user type, but they have known for a long time that a lot of people were sold a product they did not want. There is nothing stopping them from updating firmware to allow those people to use the drive in a more tradtional way, after all, if wd cant figure out a bit of drive stuff, who can?

bunch of arse

1 Like

Hi @gibbsyns3,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask