My Cloud Home deleting newly transferred files - not keeping files


Since the last My Cloud Home app update, whenever I transfer a new movie file from my laptop to the My Cloud Home drive using the desktop app…the file looks like it has transferred…but then after a few minutes…the file dissapears. I tried again …and the same thing occurs…teh file dissapears.

I ca delete existing files, rename existing files…just cannot add new files to My Cloud Home. It’s only 50% full.

I noticed that when you log in with the desktop app thaat the web page it takes you to log in…has two green ticks to show you have connected to your account…and the device. But I only get 1 tick for the device so I’m guessing this is the problem.

I have tried the online chat to WD support but they keep just sending links to stuff to check as if I haven’t tried to fix it. What I want is for them to TeamViewer in and look for themselves.

Has anyone else had this issue? What is the fix?




I am having exact same issue after the firmware upgrade. The newly added files are disappearing randomly. I have created new folder and added few files. Those files got deleted. Not only that, I synced a specific folder on my laptop. WD’s sync also deleted files from laptop. Surprisingly, those files aren’t moved to recycle bin but simply deleted.

I tried adding the files multiple times but same result. Both local copy and WD copy are disappearing. It has become very unreliable and can’t trust the storage on WD.

Is there any update on this? I got reply from WD stating, their internal “db” is out of sync post the firmware upgrade. They have no way to correct this issue and that they want the harddisk to be reset (by loosing all the data) and use the product. There is no guarantee that, the product will still work after this and that this issue won’t reappear.

Should this not come under faulty product and replacement should be arranged?

1 Like

Hello, no update from WD. My next plan is to find a Linux guy to get in to the HD and see if he can find out what’s happening.

My movies still play so I know that those files are on there somewhere. I just can’t see them or add more files.

“Arggghh”… Best wishes for that.

My product is still under warranty but not sure if I will get any support from them.

Yep I think this is “beyond Windows” to repair (if I can repair lol). I’ll post when this dude terminals in and can see what looks weird.

1 Like

Got the same problem. Newely added files and directories get deleted after a short while !!

Me too, same problem - I believe that the last firmware update made My Cloud Home unusable. All my new copied files are deleted (actually, they are simply disappearing) at random intervals, after a few hours or after two or three days.

Does anyone know a solution?


We have reached out to you via direct message, so we request you kindly check and reply to your DMs so that we can assist you further.

I just updated to the new firmware today 5.24.108 and now I cannot copy files to the Cloud Home I’ve had for 11 years. It says “not enough space to copy file” and “0 bytes required to copy file” but there’s about 800 GB open.

This is a major problem. Can it be fixed by reverting to the earlier firmware version?

1 Like


We have reached out to you via direct message, so we request you kindly check and reply to your DMs so that we can assist you further.

Hi everyone - update so far.

Still no fix from WD. It’s beyond the standard tech support team I think. This needs a development person who understands Linux and who can either “dial in” to the underlying Linus OS and see the folders (and hidden folders - which is where my files will be) and find a fix. I’m no Linux guy at all but there seems to be a bit of banter in the Linux forum around “permissions” so it may also be tied into that too. If you have no permission - you can’t have access.

A chap from WD has reached out now so will provide you an update once we’ve spoken.

By the way…there’s a WD Discovery update out…version 4.4.407 for “Bug fixes and Enhancements”, So before I update I want to know what bugs it’s fixed, and what enhancements… in case it blows away my lost files completely.

chat soon!!!

1 Like

Yes, why is it so hard to find out what is in the release. Is it because it is going to be the last release and perfoms some sort of downgrade? I hope not.

It is said to be fixed in newly released 8.12 for MCH.
But I just noticed I have the same issue with my My Cloud EX2 Ultra with 5.24. Hopefully there is an update coming to fix it.

1 Like

Well my final update on this issue with the MCH deleting newly transferred files and…removing a folder FULL of my movies & TV shows.

WD responded and their standard answer was to reset the MCH to defaults. No discussion on “send it to my local WE Linux guy to check a few things” so I was on my own really.

So I took the MCH to a Linux friendly mate (forgive me if I get this next lot of terminology right) ….we removed the HDD from the MCH (which was a single drive but looked like some sort of mirror smarts on the front end with a PCB of components)…anyway he hard cabled it with his HDD connection kit and could almost like Hyperterminal into the drive a bypassing the windows front end with some DOS prompt like commands. Linux syntax’s etc.

He could see the hidden folder that had all my content on it but couldn’t access it to move the contents. His thoughts were that somehow the mirroring was all out of synch and was out of his knowledge - maybe to do with that PCB full of electronics. So that was a bummer - it looks like I will lose all my content.

So I had to copy all the content I could see to an external drive before the big MCH reset procedure…which is simple. Did that. Blank MCH and transfer my remaining files back again. Transferred new movies across and it works as it used to. Back to normal minus 1TB of content.

So that’s it…WD had no idea why their product after and update failed to perform. Tor their credit…a chap did dial into my laptop to witness my findings and navigate around. But my offer of getting WD’s Linux guy to look…didn’t want to know.

Good luck guys. If you had a similar issue…I don’t like your chances of finding it. Just transfer off what you can and reset the whole unit to defaults and start again.

Cheers …and happy new year 2023 :+1:


Thank you for reporting back with useful information as there are too few MCH owner who does. As to “WD had no idea”, I won’t be too sure as they did an high-wire act with their upgrading an OS (OS4) from Android to Debian and kept the old volume and data in partition 24 of the HDD - what that did was created a whole slew of permission problems with folders and files created by old apps such as Plex and SMB clients (Windows and macOS) that may no longer be written again by the new admin of Debian OS4. So of course WDC knew, it is just that they can’t offer much help other than asking the user to reset to factory as some files without the proper write permission would appeared to have written to a folder in a volume but will be soon deleted.

But you did exactly the right solution, backing up the MCH before you lose anymore data and reset and repopulate your disk from backup data.

As to this situation being unique to MCH or WD, it is not - it is often seen in upgrades of other NAS where the old volume became incompatible with the new OS and their solution is the same, this one from Synology: