My Cloud Home 2TB: WIN 7 PC Sees It, WIN 10 PCs Do Not


#1

OK,

I’m replacing my final WIN 7 machine due to cyber-arthritis.

The WIN 7 machine sees the MyCloud Home via a Mapped drive, but it doesn’t via the NETWORK link in File Explorer.

BOTH my laptop and the new desktop (WIN 10 HOME) cannot see the drive, with one exception:

  • After installing WD DISCOVERY, the drive is mapped to DRIVE Z and the FAMILY directory is available. But, my data is not in the Family directory, and I can’t seem to find a way to get the WIN 10 machines to see the other parts of the drive.

I have:

  1. Changed the setting on the WINDOWS FEATURES to address the SMB issue (and yes, I rebooted).

  2. Rebooted the MyCloud Home (pulled power cable, re-inserted).

  3. Rebooted the router (NETGEAR NIGHTHAWK Series)

  4. I ensured NETWORK DISCOVERY is on.

I have made sure WIN 10 is fully updated,

Your help is appreciated!
Rampager83


#2

Did you put the contents in \My Cloud XXXXX\Public Samba Share?
If so, use the IP address of your MCH in Windows Network Explorer like this

\\IPOFMYCLOUODHOME\Public


#3

It won’t connect. Tried in browser and FILE EXPLORER.


#4

What’s the error message that you get?
Here’s mine

EXAMPLE:


#5

Not sure of the firmware you may have on your WDMycloud. I stopped updating mine due to connection problems. Running WDMyCloud v04.05.00-315. However I ran into an issue just yesterday with my windows 10 and the latest update. Be sure you have your Mycloud IP address in the hosts file (\windows\system32\drivers\host) it can be edited with any text editor.
Here is a sample view.