My Cloud® EX4100 Storage Device Firmware 2.10.310

Hi all,

My EX4100 is now reporting this firmware is available for download and the Release Notes indicate the following fixes :

Resolved Issues:
 Resolved issue of Network connection failure on Android after firmware update
 Resolved issue of My Cloud device unable to reconnect to the new relay servers after relay fall over
 Resolved issue of Apache fail to start due to corrupted SSL keys
 Improved analytics support

Just wondering if anyone has installed it yet and what feedback they may have on it ?



1 Like

When I attempt to upgrade the firmware to version 2.10.310, everything appears to work correctly, but in the end the device still report version 2.10.302.

This happens with both manual and automatic upgrade. I’m using a Windows 8.1 client.

Any suggestions?

Thank you


We have passed this for further investigation. In the mean time, have you tried resetting the unit and performing the update again?

Yes I have rebooted, several times.

Thanks for looking into it.

I’ve upgraded and now I can’t see the EX2100 in my “Network” (open “File Explorer”, on the left “Navigation pane”, you’ll see a location named “Network”) in Windows 10.

I can, however, open it by typing “\\WDMyCloudEX2100” into the “Run” app.

Edit: Guys, I was able to make it appear again, have a look if you’re experiencing the same issue.

I had the problem of not being able to see my NAS on the “Network” view (open “File Explorer”, see the “Network” section within the “Navigation pane” on the left) with Windows 10 Pro Insider Preview - Build 10565.

I was able to connect to it by typing in the hostname (\\WDMyCloudEX2100) or its IP (\\192.168.x.x) into the “Run” app and when I did this, even the address bar in “File Explorer” showed that it was in “Network” (it showed “Network > WDMyCloudEx2100” or “Network > 192.168.x.x” depending on the particular access method, to be exact), but when I backed-up one directory from this view, (back into “Network”) it was still missing (there were no computers showing up with a name such as “WDMyCloudEX2100” or “192.168.x.x”).

While experimenting with the NAS, I found out that I was able to make it appear in “Network”, only when I choosed “SMB 1” on my NAS (Settings > Network > Max SMB Protocol), and I’ve tried several other times to ensure that the results were consistent. Please ensure that enough time passes after changing the SMB setting on the NAS, as it could take up to a minute on my environment for the change to become effective.

Note: The default setting when performing a “System Only” restore on WD My Cloud EX2100 at firmware 2.10.310 seems to be “SMB 2”.

Hi all,

I just did the update on my EX4100 with no issues to report. All worked better then the previous update I had installed.

Hope the others of you experiencing issues can get your issues sorted…



1 Like

usually hate “me too’s” but, my manual FW upgrade worked flawless. Thank you WD!

One question about the release notes – what does that mean?

1 Like

Would really love to learn that…

I expected some kind of improvement with the “Device Activity” window but no luck! :pensive:

For example, I would really love to see the I/O activity on the drives (like read/write MB/s values for each drive) etc. and not only “Network” activity. Because some processes does not involve the network. For example, the “P2P Downloads” app (Apps > P2P Downloads) works on its own and writes to the internal drives… Or the “Web File Viewer” app also does the same, no “Network” activity is recorded when copying files from one location to another as it all happens inside the EX2100; I can copy 500 GB of data but will have no way to monitor I/O throughput on the internal drives, other than through SSH (and not everyone would be comfortable with that).