My Cloud EX4 problem after joining to the domain

Hi All,

I have a My Cloud EX4 with RAID 1 and with firmware to the latest one - 1.05.30

I created a Raid 1 and also a few shares. Everything was fine before i join this NAS to 2003 domain.

After joining to the domain all shares disappeared and can’t be accessed on a share.

Tried to rejoin - didn’t help.

Disjoin from the Domain, Change Link Aggregation to 802.3ad, join, reboot – didn’t help.

Also when i try to open the dashboard, when it in the domain, no users and shares are available.

Do you have any suggestions?


Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

I tried,

Didn’t help.


In order for shares to be seen when you join a domain, you need to join the domain first.  Anything you make before joining the domain won’t be visible once you join, with the exception of ISCSI shares, from my experience.  I had the same issue and a device System Restore (SETTINGS/UTIILITIES) got the shares back after I removed it from the domain.  It will reset all the settings to default, but not delete data.  I then copied the data to another drive, and removed the shares, then rejoined the domain. 

As for seeing domain objects, my first suggestion would be to make sure you have the latest firmware.  I had bought my EX4 when they first came out and it had an early firmware which was really buggy regarding the domain.  It would sometimes show my users and groups, othertimes I would have to rejoin.  It’s much better with the newer firmware.  However, I  did not join anything below 2008r2, and am now using 2012r2, so I don’t know if there are any issues with the older OS.