My Cloud ex2 ultra issues: unable to login after setting static ip

Hi all,
I am a new user of the my cloud ultra 2x2 drive. I have set a static IP address on my router on a separate and cannot access the web console any more. I have separate subnets for static IP addresses.
How do I get around this? I did see a solution of setting an IP address on another network interface. The problem is that there is only one LAN interface.
I have managed to get ssh access but that is not helping I did do an ifconfig and can see a docker network interface as well.
I do not know if I can add or change any interface.
There is no /etc/network/interfaces file.

Pranav

I havent read this in detail, but it might be useful?

Hi,

On my box too, the docker IP address is different (172.x.y.z while the NAS main IP is on 192.168.x.y).

Is apache up listening on port 80 ?

ps -ef | grep apache
netstat -an | grep LISTEN => check for port 0.0.0.0 : 80

If yes, check the restriction in the config file:
/usr/local/apache2/conf/httpd.conf

Modify the “Require ip a.b.c.d/n” to match your subnet.
Send a SIGHUP to apache.

Aleph/Ayin

Hi Aleph/Ayin,
I could modify the httpd.conf file but that would mean that my modification would be lost upon every reboot I believe. If that is wrong, then please correct me and I’ll gladly make the modification. The WD solution is to enable cloud access for the dashboard. I have UPNP disabled in my router therefore, I believe the cloud access is not really sending out anything but I am not sure.