My cloud ex2 ultra Does not provide power to hard disks

I got “my cloud ex2 ultra” with two 4Tra discs
It has two hard drives red version

I took out the discs in order to put other 1Tra discs

Now the problem
When I return the 4TR disks
They do not turn on (do not receive electricity)
The device itself turns on but does not supply power to the discs
There are three LEDs on the front of the device
The first is lit in blue
And the bottom two are lit in red

The discs themselves are good
I connected them to another device and directly to the computer everything is fine

But that I put them in “my cloud ex2 ultra”
They do not work
I tried to hear or feel the discs
They do not receive electricity and do not work

When I browse to the graphical interface of the device I get a message to put hard disks and click next

If I put other 1Tra or 500GB disks
Everything is working fine

I want to return the 4TR disks to the device
How to fix it

How to fix it

@mark4 I would like to make sure if you are using the original power supply the one that comes along with the device when you purchased.

This is not the original supplier
The current supply is 12 volts 5 amps
I tried switching some 6 amp to 12 amp supplies
no change

It worked with the current power without issues with the 4Tra discs

What could be the problem

up up up?

These disks worked on this device
So what could it be

@mark4 Thank you for posting the issue, I would recommend to check the warranty status and then online RMA request.

it is not under warranty
so rma is Irrelevant

Is there a way to fix the problem?

up up

Depending on the HDDs you put in the system, using power adapter that doesn’t provide enough power may cause problem like you described.

For the EX2 Ultra, it uses either a 36W or 48W power adapter:
12 VDC, 3A for 12TB, 8TB, 4TB SKU
12 VDC, 4A for 0TB, 16TB and above SKU

I received the EX2 Ultra with a 5 amp power supply
And with two 4Tra discs inside and working

The only thing I did was take out the discs and put others
Now I want to return these discs (the ones that came with the device)

I tried to power with a higher amp up to 12 amps
It did not change anything

up up