My Cloud EX2 is not reachable as network unit


The EX2 unit does not appear in the NETWORK tree at Windows 7. It only appears when I click in NETWORK icon and go to the explorer window. Then, the unit is visible in the NETWORK tree but with the IP address in my home network and not with the unit name.

I cannot use it as regular storage unit either with backup or sync tools.

Thank you for your help.

Hello and welcome to the WD community

Try to reset the unto see if after resetting the drive it comes up, also make sure that the drive and the computer on your network are on the same workgroup. Does this happen on more than one computer on your network?

Thank you for your fast reply.

I reset the EX2 unit and happens the same.

I have an old Acer with Windows Vista and Macbook Pro with OSX El Capitan in my network. Workgroup is set in all devices as WORKGROUP.

In Windows Vista it works well.

The Mac never worked well. Installation software could never detect the EX2 into the network Time Machine either.

In Windows 7 still does not work.

When I open an Explorer window, I see only the computers into the network, but the EX2 is present. I do double click and I can see the unit, but with the network IP, not the name, and I cannot use backup utilities like the one in Windows or FreeFliSync


Have you tried setting your router to assign a fixed IP address to your EX2? I was having the same problem with windows7 when setting a variable IP address to the EX2. Since I set my router to give it a fixed address, the EX2 has been recognised in windows explorer every time without fail.

Yes, I tried. Same result.

Any solution to this ? i have same issue.


This lack of displaying your EX2 could relate to which device on you network is the Local Master Browser for your SMB shares.

Essentially if no device is specified as the master, then some device will pick up the task and provide the information accordingly. However, from my experience, not all Local Master Browsers perform the task equally well and I’ve seen such a problem exist from a poorly coded/poorly working Local Master Browser.

If you don’t have a Local Master Browser set up, then (at least with my EX2 Ultra), there is a setting within the network settings to have the EX2 Ultra unit be the Local Master Browser; turn this on.

I found my SMB shares populated properly with using the EX2’s Local Master Browser (had to reboot my computer to repopulate the network shares properly).