My Cloud EX2 full LAN/WIFI access but remotely no files/pictures available

Dear All,
I have browsed through many topics but non has really described my situation. I hope and thank everybody in advance who can contribute something.
So, LAN and WIFI access to my EX2 works perfectly and fine.
The problem is the remote access and here it’s not the usual case:
I can access the EX2 via App and Webbrowser, I can see the folders BUT

  1. sometimes I cannot access the folders in which files are stored
  2. sometimes I can access folders with files, but they the files not displayed, loaded and cannot be downloaded
  3. in one case I can access and download the file but in that folder there is only one file and that is a kdbx

After a while a get an error message (503) that the EX2 can not be accessed. After another while the access works again, but the above described problem remains. UPnP is actived on the router. Latest firmware installed. Static IP used.
What’s so strange to me is, that the access works perfectly from the LAN and WIFI and also remotely there is access available, but the file viewing and downloading etc. does not work.

I’m having the same issue.

I can access with WIFI, today suddenly I could not access via App or files.mycloud.com.

I think there is an issue with mycloud’s servers

I have access to the cloud from my device

However not from files.mycloud.com

Hi Guys,
I get me Internet via LTE router. It seems that my last “discount” ISP (Austria Delight Mobile) somehow blocks the access. I have tried another SIM in the LTE router and now the access works again. I’m still not sure how that works at all, because I had access to the NAS from remote, but pictures and files would not load and could not be downloaded…
I mean I have access again, but still, out of curiousity:
Can that be solved by using other ports? How can such a block work?