My Cloud drive is spinning but not connecting anymore

I’ve had My Cloud for about 2 years, its worked great. The other day I could not connect to it anymore, I can’t access the panel either. The blue light in the front is not working, the only light working is the green light in the back for the cat5 cable. I can feel the drive still spinning thought. I tried connecting straight to my iMac via the ethernet cable, everywhere I read it should show up in the finder but nothing. Any suggestions would help, thanks.

What happens if you unplug it, wait a few seconds, then plug it back in? Still no lights? If so, sounds like your unit has failed.

Yeah, I’ve restarted both the drive and my router, I tried reseting both the 4sec and the 15sec methods with the pin on the drive. If the unit has failed can the hard drive be taken out and work on a docking bay or is there more to it?

It can be that simple, but you’ll need some software that understands the linux-based file system used by the NAS, called EXT4.

Just about any Linux “Live” distro will do it natively, or you can use Diskinternals’ Linux Reader within Windows to access the files.

Hello, I´m from Spain and I am having exactly the same problem as you.
I purchased my WDMy Cloud 2 years ago (just like you).
My blue light has also disappeared but instead of it I have a yellow one, you don´t have any light???
(in the backside I have the same light than you).

I´ve tried a lot of solutions (connecting via USB or via ethernet cable directly to the MacBookPro, I´ve changed the power cable…) but It doesn´t work.

Even, I have realized that when I installed my device I used to receive an alert email when there was any problem (for example, if it had been disconnected, or if there was any kind of update…) but at this time I´ve not received nothing (I was checking in order to know exactly the date of the problem when I realized it).

Could be the problem related to some kind of software update from WD??

Anyway, I´m terribly desesperated because I have a lot of information in my device and it would be horrible to lose it. I guess that you are in the same situation.
I think that I´m going to take it to a technical service, but here in Spain it´s not easy.

Well, if I find any solution or information I will tell you; I would really appreciate if you could do the same.

Thank you so much in advance

@TonyPh12345 i’ll try to figure that out…Im on a mac and don’t have access to a linux machine.

@jose_manuel_gonzalez looks like we are in the same boat. My drive doesn’t even have the yellow light, it is very frustrating because I do have a ton of work on this drive. I should have know better not to trust this with out backing up. If I figure something out I will let you know, thanks.

@TonyPh12345, I finally came back to working on this problem. I ended up loading parallels on my imac and installed ubuntu 16.04lts. I connected the dock via usb with the WD red HD on the dock but nothing shows. The drive still was spinning when it was in the My Cloud casing so the HD is good. Is there something specific I need to do in ubuntu or should it automatically show up like every other drive on my network? Is there software I need to download in ubuntu to read the ext4? Thanks for any info!

You would probably need to mount the drive. Google for details.

Thanks, I’m looking that up.

So, I got it to mount, but I only see the free space of a 4tb drive. The other 2tb has the content Im trying to save. Any suggestions?

/dev/sdb is for the entire disk. For what ever reason it thinks your disk is only 1.8 TB. If it was on a gen1 system try to mount /dev/sdb4. If a gen2 try to mount /dev/sdb2. That is where the data should be located.
From a command prompt on Linux. Type mount /dev/sdb4 /mnt Then if it mounts cd to /mnt and do a ls command.

Here is what I get:

gilbert@ubuntu:~$ mount /dev/sdb2/ mnt
mount: only root can do that

Space between /dev/sdb2 and /mnt

Be careful to copy the command correctly.

Why aren’t you logged in as root? Try prefixing the commands with sudo.


lbert@ubuntu:~$ sudo mount /dev /sdb2 /mnt

mount [-lhV]
mount -a [options]
mount [options] [–source] | [–target]
mount [options]
mount []

Mount a filesystem.

-a, --all mount all filesystems mentioned in fstab
-c, --no-canonicalize don’t canonicalize paths
-f, --fake dry run; skip the mount(2) syscall
-F, --fork fork off for each device (use with -a)
-T, --fstab alternative file to /etc/fstab
-i, --internal-only don’t call the mount. helpers
-l, --show-labels show also filesystem labels
-n, --no-mtab don’t write to /etc/mtab
-o, --options comma-separated list of mount options
-O, --test-opts limit the set of filesystems (use with -a)
-r, --read-only mount the filesystem read-only (same as -o ro)
-t, --types limit the set of filesystem types
–source explicitly specifies source (path, label, uuid)
–target explicitly specifies mountpoint
-v, --verbose say what is being done
-w, --rw, --read-write mount the filesystem read-write (default)

-h, --help display this help and exit
-V, --version output version information and exit

-L, --label synonym for LABEL=
-U, --uuid synonym for UUID=
LABEL= specifies device by filesystem label
UUID= specifies device by filesystem UUID
PARTLABEL= specifies device by partition label
PARTUUID= specifies device by partition UUID
specifies device by path
mountpoint for bind mounts (see --bind/rbind)
regular file for loopdev setup

-B, --bind mount a subtree somewhere else (same as -o bind)
-M, --move move a subtree to some other place
-R, --rbind mount a subtree and all submounts somewhere else
–make-shared mark a subtree as shared
–make-slave mark a subtree as slave
–make-private mark a subtree as private
–make-unbindable mark a subtree as unbindable
–make-rshared recursively mark a whole subtree as shared
–make-rslave recursively mark a whole subtree as slave
–make-rprivate recursively mark a whole subtree as private
–make-runbindable recursively mark a whole subtree as unbindable

For more details see mount(8).

There is no spac between dev and /sdb2.

sudo mount /dev/sdb2 /mnt

gilbert@ubuntu:~$ sudo mount /dev/sdb2 /mnt
[sudo] password for gilbert:
mount: special device /dev/sdb2 does not exist
gilbert@ubuntu:~$ sudo mount /dev/sdb4 /mnt
mount: special device /dev/sdb4 does not exist

hmmmm…the 1.8 TB shows under the disk app, but isnt mounted. will the right command mount it just like all the other drives showing up? Im ahead of myself because Im hopeful this will be figures out. Thanks for getting me this far, BTW.

Here is another screen shot, there seems to be a command out there that will see that other part of the partition


What Gparted is showing, is that the disk is not partitioned. It is like the disk just came out of the box.