My Cloud does NOT deliver large JPG pictures (>6 MB) to smart TV, why?


#1

I have been enjoying WD My Cloud 4TB since 2013. However, since I got a new camera, Sony A7R2, my smart TV has no longer been able to display new pictures from My Cloud. These pictures are in JPG format and of size 15 MB to 45 MB. What the TV displays are tiny icons of 10 KB of the pictures. This is definitely not the problem of the TV because I can display the same pictures by directly inserting a USB drive in the same TV. All the computers can also display the same pictures from WD My Cloud. Is there a configuration in My Cloud server that I have to adjust? Such a limit to the picture sizes has made WD My Cloud useless for my purpose of a live picture library. This is a serious problem.


#2

Yes your TV could be the problem if it accesses the My Cloud using DLNA versus accessing the USB drive via some type of file manager method. Often smart TV’s access the USB drive differently than a network attached storage device that is running a media server like the My Cloud. You first need to figure out HOW the TV is accessing the My Cloud, is it using DLNA or some type of direct file manager type access. When accessing via DLNA the Twonky media server embedded within the My Cloud will serve up the graphic file and its on the DLNA client on the TV to properly display that graphic file.

What make/model is your TV?


#3

@Bennor

I agree with your assessment. I have noticed numerous times that DLNA (and DLNA receivers like a smart TV) are not always what they purport to be, whether it concerns music, videos or photos. There are just too many instances in these forums of things not working right via DLNA, but they do work OK from a shared source device or a USB flash drive (or drive) inserted into TV. A big problem with Smart TV is most can only access via DLNA, not shared sources like a WDTV can do.

The OP can see the photos from the My Cloud on his computer, but not on his Smart TV. So, how can it be the My Cloud at fault here? It can’t.


#4

For what ever reason seems quite a few have trouble with certain Samsung smartTV’s based on the numerous threads that get posted here looking for help streaming from the My Cloud to certain Samsung TV’s.

Only other suggestion for the OP is, if the TV is accessing the My Cloud via DLNA, is to check the Twonky administration settings, Sharing > Media Receivers section to see what media receiver Twonky is using for the TV experiencing the problems.


#5

Cause Smart TVs are not that Smart yet is actually the answer. :smile: IMHO.

Yes, it is a bit ironic but also the true. They are getting better everyday though…


#6

Hi, Bennor!

My TV is Samsung UN65HU7250 FXZA

In your another post you suggested checking media receiver. In my case, getting into Setting -> Media -> under "DNLA server, Media streaming (ON), then clicked “view media player”. It displayed: Generic Media Player. I did not click the “OFF” button, which must have been “ON”.

Please advise more.


#7

@kennewor, In my post above I was taking about the Twonky Administration page which can be found at (if you haven’t changed the name of your My Cloud) http://wdmycloud:9000 with a web browser. Navigate to Settings > Sharing > Media Receivers. Then click on Show. Under Media Receivers will be a list of DLNA clients (by MAC Address and IP Address). Find the entry for your Samsung TV and see what it shows for the Media Receiver Type. Sometimes the wrong Media Receiver Type can cause problems.

If you do a search for Samsung in these forums and an internet wide search you’ll find that the DLNA client within certain Samsung TV’s has problems with the My Cloud and other NAS units. People have a variety of problems that they blame on the My Cloud when in effect it is the fault of the DLNA client embedded within the Samsung TV.


#8

Problem solved! Bennor, thank you so much for your advice. You pointed to the exact place of problem. In case any one has the similar problem, here is how to solve:

step 1: open a browser such as Chrome and go to port 9000 of MyCloud, i.e.,
http://“my cloud server ip#”:9000
step 2: click “Sharing” in the left column (the third item under SETTING);
step 3: scroll down the page and find “[TV] Samsung xxxx” (some info about the TV) in the second list, “Media Receivers”. In my case, the Media Receiver Type was “-/-” which was the problem. Click on it, then a long drop-down list enumerates hundreds of device types. I chose “Samsung Smart TV”.
step 4: Click the “Save Changes” button at the bottom of the page.

Large JPEG pictures (as big as 15 MB) are displayed properly by the smart TV. I love WD MyCloud again.


Media receiver type setting in MyCloud Mirror Gen2?
#9

Hello, I just bought a WD My Cloud 3 TB. I can access it through my PS4, but there are some JPG that can’t be opened. In fact, the PS4 media player throught the DLNA dosn’t show them, some folders seem to be empty but there are pictures on them, is just that the PS4 doesn’t show them.

I think I have the same problem as the user who bought a new camera because I can access the JPG pictures from my old camera but I can’t access the JPG pictures from the new one, a Nikon D7200.

If I go the Twonky administration page, the PS4 is recognized as a PS3 and I there’s no PS4 option to choose instead of the PS3.

Any ideas of why those JPG can’t be seen on the folder? JPG size go from 1 MB to 15MB, but none is seen on the folder.

Please, help me! The main reason I bought the WD My cloud, appart from doing a new copy of my files, is to access my pictures throught the great picture viewer from my PS4.

Thank you so much.
Rafa.


#10

I’ve applied that solution and now it works fine: https://support.wdc.com/knowledgebase/answer.aspx?ID=17802