My Cloud disconneted itself from network

Mine was up and stable for a week when it was plugged into an old 10/100 4 port hub.  I replaced the hub with a Trendnet GB switch two days ago and now it disappears after a few hours.

I am curious if anyone updated the firmware and the unit is staying connected. As mentioned earlier, the update doesn’t appear to address the dropped connectivity within the network.

I did update to xxxx.165 (latest firmware) and it keeps dropping off the network.  So apparently it’s not fixing the problem.


I don’t think this issue was addressed.  I’m sure we’re still working on this and will get a fix out asap.

So I updated to the -165 firmware yesterday. Since rebooting the box has been up for 1 day 11 minutes now, with no unexpected disconnections. The firmware update reverted my change to the vm.lowmem_reserve_ratio and I left it alone (“1 1”) instead of changing it again to “16 16”.

To recap, with the previous f/w it wasn’t able to stay connected for any longer than 8 hrs, often much shorter. After changing the vm.lowmem_reserve_ratio, I didn’t see any disconnections over 8+ days. And with the new f/w with the old vw.lowmem_reserve_ratio, I haven’t seen any disconnections yet in over 24 hours.

I don’t know what to make of all this, but as long as the box is stable I’m not too worried about it.



Upgraded to the latest version yesterday. Problem still exists.

I will now try the crontab solution.

Please note that you should use “date > /DataVolume/shares/Public/date.txt 2>&1” in stead of “date >> /DataVolume/shares/Public/date.txt 2>&1” 

means append, so although a small amount of data is written to that file, it is written every minute and will use up space and will eventually fill up your disk.

will overwrite the file every time, so it will not grow

Edit: Problem occurred again after 1 hour and a half. Will now try with >> , see if that makes a difference.

Edit2: I think the issue was related to a temperature problem (I had it in a closed compartment). NAS has ben up & running for more than a day now.

I bought a new My Cloud and setup last week. That went well and felt pleased with myself, but the next day when booting up the PC, I could not see the drive unless I manually reset the My Cloud by turning off power. No remote access either. After reset, I could see the drive again.

Tried a few times over a few days then saw the post about running the setup software again - it now works. I can power down PC and when booting back up MyCloiud is there.

@ Kmurphy,

Did all that, but no cigar, no change.

Another thing now is, when I want to start or install a program from the WD My Cloud, you need to run it as Administrator and then first give in your login name and password, but still it is very slow and has the tendency to tell you “Don’t know who has written this software” do you want to run this ?

You press run and then it locks up your computer. Aggghhhh ! Then you have to go to Task Manager and click 10 times end program to get your computer responding again. Never had this with my other NAS’.

Keep going like this WD, I am telling you, my report will not be good if it stays like this. You will hear this on Tuesday, when your second level Engineer is calling and I will tell what is going on with this thing.

@ Lin_admin,

I am telling ya, I will poke at da WD gods and they will comply. :wink:

The new firmware  03.03.02-165 seems working.  My previous cron job stopped upon an auto upgrade of firmware at 3 am on Jan 30.  MyCloud has not dicconnected from my network up to now.  The auto sleep seems working, too.  The blue light blinks after being idle long enough.  An attempt to access can easily wake up the box.  Many thanks to Bill_S. 

@ Kennwor,

That was it doing before I started copying my 680 Gb and left it at that. Now it stopped doing that and disconnected overnight since yesterday after full backup. Could not connect nor use Dashboard or IP address, was not pulsing either in blue light even though Sleep button was on.

A question, where is yours coming from ? Thailand, Malaysia, China,  and where did you buy it ? If I may ask. Thank you.

Here is my story on the disconnects and what worked for me (for now).

I purchased the 2tb MyCloud about a month ago.  Right out of the box evrything worked great.  My phones, laptop and desktop linked up to MyCloud and everything backed up smooth as a baby’s…  Anyway, after ~4 days, everything came to a screeching slow speed.  I think the unit is actually not disconnecting but very slow to respond.  My UI would take 3 - 4 hrs to display user name/password screen (maybe).  Most of the time it didn’t display.  After puling the plug from the unit and restarting, everything would work fine for about 4 days.  Tried disconnecting some things and disabling sleep mode and it didn’t work.  Last week, I did a full system restore and manually updated firmware 3.03.01 (not the latest .02 - it wasn’t out yet).  I then disabled any media streaming and itune server (I don’t need it).  I have static IP and port forwarding.  As of right now, I have my desktop and Macbook hooked up to it.  It’s been up and running for over a week without any issues.  I am hasistant of updating to the latest firmware but will do it in a week.  This has worked for me and wanted to share.

Hi, P_D! 

Mine is a 4 TB one made in Thailand and purchased through B&H Photo’s Web (NYC).  

Hello, folks!


I’m now joining this community to share my experience in using WD My Cloud 4 Tb.


So, the device works for 1-2 days and then looses a network connection on Mac and on PC. I’m not able to connect it through UI web interface with web browser or any software, Finder or Navigator on any PC or Mac. Recently when it was still working I’ve tried cnahging to static IP, also updated a firmware to the latest a day ago - no changes, it still disconnects.


I’ve talked to a support person by phone for several times, wrote multiple e-mails to the support containing full network and other possible reports, checked wires, changed them and even router - nothing helped. Just the waste of my time and nerves.


The problem for me - I am wasting my business time on this instead of hard work on my projects.

Also it is almost impossible to return this kind of a device to a retailer in Russia - they won’t accept it used. I’m not sure I will be able to return it to WD directly here.

And also, my My Cloud already contains some data that I don’t have anywhere else stored - so I now need to reconnect it somehow and get it copied.

This all drives me nuts!!!


So, people there at WD, this is a crazy situation!!! Why don’t you guys pay more attention to this specific problem and try to fix this issue somehow now?!


In other case - people who are going to buy this device - please find and read these topics with Google, hope you think twice carefully before dealing with Western Digital.


I’m highly dissapointed WD, SHAME ON YOU! :angry:

Well the last upgrade cured my disconnecting every night.

However the latest not only caused huge hassle with losing all the settings and having to do a complete reboot with the reset to get it goping again which tool many hours. It is now disconnecting every night again!!!

How can I roll back to the earlier firmware on which it stayed live for the whole time it was installed, several weeks?

Had to reboot again this morning, got it going and watched a film on it. Then tried to use it again about 30 minutes later and gone again. Furtjher reboot needed.

Just about unusable at the moment.


Now three weeks of continous uptime with your solution.  Thanks!

I read Steve’s writeup and what he is doing is preventing the drive being put to sleep, and that should provide someone with a valuable clue.  I wonder if this is a software or a hardware issue?  Some of us, knock on wood, have never had this issue, and others have it continually.

For those of you that are still suffering from this disconnection issue with the My Cloud.  I created a new thread for the product people.  They need more information in order to effectively divide what issues are which.  You will find the new thread at the link below.  Please help us by posting your information in that thread.

We won’t be monitoring this thread any longer, so I am closing it.