My Cloud disconnects while streaming video

I have a My Cloud (firmare v04.01.04-422) and while I stream videos to my TV over an ethernet connection, I consistently get disconnected from the server.  I was reading this threadand hoped modifiying the Twonky settings would resolve this. Even after unchecking the ‘Restart on NIC chnages’, I am still getting disconnected during the stream.

Is there anything else I can do to resolve this?  Is this expected behavior or can I contact WD for a new drive?


Can you test with other devices other than your TV to see if it really is the WD My Cloud that is disconnecting or if its your TV that is at fault. If it is only confined to your TV then conact your TV manufacturer’s support (or their help forums) and see if there is a fix or workaround.

So I tested this on a MacBook by having a video play in Quicktime, in the background.  I didn’t get any error messages, but also wasn’t watching it for 2 hours while it played.  When I did check in later, it seems to have completed fully, but I can’t verify that.  This is a small sample and there were times with my TV where the stream was not interrupted.  Is there something on the TV I need to ensure is configured properly?  This is a very new TV purchased in November of 2014.

 Is there something on the TV I need to ensure is configured properly?


But first, you should check the user manual of whatever TV you have, and see if there is a list of media formats it supports via DLNA, and check to see if it supports the media file type you are trying to play.

Also use the Twonky UI to see if there is a ‘Media Receiver Type’ that matches your TV. See the Twonky FAQ for information on that.

The TV is a Samsung UN65H6300AF and does support the codecs I have tried (H.264, MPEG 4).

The Twonky ‘Media Receiver Type’ is set to ‘Samsung Smart TV’.

I feel this is a My Cloud issue as the media will play fine for a certain period of time.  I have previously used DLNA servers on a MacBook that never had connectivity issues with the same TV so the signs are pointing to something on the My Cloud.  Any other ideas?

smugcloud wrote:


I feel this is a My Cloud issue as the media will play fine for a certain period of time.  I have previously used DLNA servers on a MacBook that never had connectivity issues with the same TV so the signs are pointing to something on the My Cloud.  Any other ideas?

If you do a search through these user support forums you’ll see that Samsung TV’s are having all sorts of problems playing content from the WD My Cloud. While you may have not had a problem using a different DLNA server, the problem may be an incompatibility between Twonky, the DNLA server within the WD My Cloud, and Samsung. Seems some who use other NAS devices (like QNAP units) are also experiencing issues with Twonky and Samsung TV’s. It has been said before in these forums that smartTV DLNA clients tend to be problematic when playing content from Twonky. The first step, as always, is to ensure both the TV and the NAS are updated to the latest firmware (and DLNA client/server). Next is to ensure its not a problem with the video file itself. Try encoding the video into another format that is supported by the TV’s DLNA client as a test. Because certain video formats are “containers” they may encoded by an encoder that is incompatible with the DLNA client on the TV.

The Twonky ‘Media Receiver Type’ is set to ‘Samsung Smart TV’.

Is there just one Samsung Smart TV on the market…?  No; there are lots, of different generations. And I don’t expect for a moment that they all have consistent firmware or protocol or media type support. ‘Smart TV’ is a very fast-moving consumer market. So that setting might suit your particular model, or it might not, or it might provide partial support.*

I have previously used DLNA servers on a MacBook that never had connectivity issues with the same TV so the signs are pointing to something on the My Cloud. 

Okay. That’s another data point we didn’t have…

It’s also possible that the other DLNA server on the MacBook was doing on-the-fly format transcoding, from one format to another format that your TV could use. The processors in most NAS devices are not really up to this compute-intensive task.

We’re not saying that the MyCloud is perfect (it’s far from it), or that the fault definitely lies with the Samsung. But they are what they are, and you may have to accept that the combination cannot do what you want.

You might also have a look at the discussion about adding media types to Twonky, on this page of the Twonky FAQ. I posted some links to pages that appear to be interesting discussions on how to get Twonky to best support a particular DLNA client, by manipulating the media type definitions in the media receiver type definition files.

* I’m currently trying to find out from Sony exactly what the purpose of the fully-functional Ethernet port is on the back of my new TV. It has an Ethernet port. I has a MAC address. It will connect to my router and negotiate an IP address from the router’s DHCP server. But, beyond that,  there is no information in the manual as to the purpose of this network connection… Sony support don’t seem to know… They’ve just asked me to photograph the rear label and the network port. I don’t think they believe me…

So this problem has continued to happen and I wanted to re-investigate to see if I can find a solution. After some recent connection drops, I have enabled logging on the Twonky server and saw this after a lost connection yesterday. I am pretty sure the disconnect happened at the 16:41:41 mark. I saw this thread and after checking the two movies the disconnect is confirmed on, they both have numbers in the file name, one already was an .m4v, and the other was .avi. I’ll try removing the numbers from the file name but does anyone have an idea/solution for this particular error message? I’m open to suggestions.

03:23:50:768  [Startup] - LOG_SYSTEM: server_main_impl : *** Starting TwonkyServer (Product Name:Twonky, Version:7.2.9-6, Build-date:Mar 25 2015) ***
03:23:50:783  [Startup] - LOG_SYSTEM: server_main_impl : using logfile /CacheVolume/twonkymedia/twonkymedia-log.txt
03:23:50:783  [Startup] - LOG_SYSTEM: server_main_impl : Executable file: /usr/local/twonkymedia-7/twonkyserver
03:23:50:783  [Startup] - LOG_SYSTEM: server_main_impl : Command Line Parameters: 9
03:23:50:783  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 1:-D
03:23:50:783  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 2:-ip
03:23:50:783  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 3:
03:23:50:783  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 4:-httpport
03:23:50:784  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 5:9000
03:23:50:784  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 6:-appdata
03:23:50:784  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 7:/CacheVolume/twonkymedia
03:23:50:784  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 8:-logfile
03:23:50:784  [Startup] - LOG_SYSTEM: server_main_impl : cmdline 9:/CacheVolume/twonkymedia/twonkymedia-log.txt
03:23:50:873  [Startup] - LOG_SYSTEM: upnp_ini_file_read_properties_impl : reading ini settings from /CacheVolume/twonkymedia/twonkyserver.ini
03:23:50:904  [Startup] - LOG_SYSTEM: upnp_ini_file_read_properties_impl : friendlyname = %HOSTNAME%
03:23:50:904  [Startup] - LOG_SYSTEM: upnp_ini_file_read_properties_impl : ip =
03:23:50:905  [Startup] - LOG_SYSTEM: upnp_ini_file_read_properties_impl : nicrestart = 0
03:23:53:614  [Error] - LOG_SYSTEM: upnp_multiuser_load : load user-db from twonky.users: failed
03:23:53:614  [Error] - LOG_SYSTEM: Error: 2 No such file or directory

16:41:40:742  [Error] - LOG_EVENTING: handleConnections : Received error in resubscribe (5064) response 412 from
16:41:40:764  [Error] - LOG_EVENTING: Error: 11 Resource temporarily unavailable

16:41:41:302  [Error] - LOG_EVENTING: handleConnections : Received error in resubscribe (5066) response 412 from
16:41:41:302  [Error] - LOG_EVENTING: Error: 11 Resource temporarily unavailable

15:04:04:698  [Error] - LOG_SYSTEM: upnp_socket_connect_timeout : connect/select FAILED after 30000 ms with error "Operation now in progress".
15:04:04:723  [Error] - LOG_SYSTEM: Error: 115 Operation now in progress

And doing some more testing on this, it looks like streaming the same video file (without editing the file name) from a Mac using VLC, I don’t experience any issues in the stream. So perhaps this is a Samsung TV setting/issue? Has anyone had better luck using a Playstation or streaming box instead of the native TV network features? That might be an easier solution…

I am having the same issue which started just 3 days ago, I had reset the twonky server, and it is still the same
I have a 2015 LG smart TV 55uf950T.
I also have a wd tv Media player 2014. I will try to play a movie and see how it goes, so I can confirm where is this drop coming from.
I have had both the TV and thr wd my cloud Nas for a long time, and all of a sudden this starts happening, the only thing I remember doing is that I have created folders from twonky, series and movies folders so that they show up at the top of my TV list of folders after going to videos.
Will check how wd tv does and let you know.
All devices have latest firmware.

Worth mentioning is that it does not not happen on the same movie… All of them, and once it happens I need to wait for 20 minutes to be able to see the movie files and select the one I was watching
Am just trying to run the movie file now from wd tv and it’s stuck

It is runs from the lg tv player, but then again it drops after 20 30 minutes

I managed to make the wd tv Media player run files,
Just a matter to same old trick… Factory reset…
Will re-watch and see if the connection drops over wd tv Media player

The same problem. “Disk disconnected” window on the TV is appear, then disk starts rescan all media content. Sometimes it happens even BEFORE streaming, but when I just open file explorer on my TV to select a video. It begins just month ago. Before that, all worked perfectly. The same TV, the same network, no any changes in HW or SW. Have no any ideas, what to do.

Here I posted my solution Video streaming stops after 20 -30 minutes

The problem was in Twonky database limitation of media files. Twonky can index only limited quantity of media, so if you over that limit, the Twonky server can’t finish the scanning process and enter to endless rescanning: after reaching its limit, it restarts and begins indexing from zero. It’s a reason of accidental disconnection. I don’t know what’s the limit. Maybe 10000 or 20000 files. I save on my disk backup of all my family photos, some music and video. So, if you only want to see your video on your Smart TV and nothing else, you may enter from your PC to Twonky setup and in Sharing options uncheck Music and Photo media types, leaving Video only. It help reduce Twonky database and it will work stable.

I have 66000+ music tracks.

Twonky happily indexes them.

They are in a hierarchical structure; maybe Twonky struggles with a flat folder with lots of files in it? But then so would I…

This also might be possible cause of the problem. But I’m definitelly behind those limits and scanning was successfully finished. See screenshot below. Maybe version 7 had limitations like this but I use version 8.5 now.

After last firmware updating (just today), the Twonky version in my WDMyCloud is 7.2.9-6, and it still can’t finish indexing all my media. It restarts every 10 min. If I uncheck all, except the video, it works fine. There are about 4200 video in database. I don’t know, how many files total I have, but from 2 TB only 140 Gb is free.

Did you try to disable regular rescanning (scantime=0 in twonkyserver.ini) and trigger scanning manually?
You can also try to manually install version 8.5 on your WD device. I found the instructions how-to do it somewhere on this forum.
You can also investigate my working twonkyserver.ini (for version 8.5 of course, but I don’t expect big difference) twonkyserver.ini.txt (16.4 KB)