My Cloud Disconnecting itself - v04.01.02-417

Hi everybody, 

since I am struggling with my WD MyCloud, I came here to get some much needed help.

As I saw in the Forum, there are already some threads about the drive disconnecting itself from the network, but they were all closed with a note to the new v04-something update. 

I am on v04.01.02-417 right now (latest from 18.Jan.2015), nevertheless I do have the issue. Some facts:

  • WD MyCloud 3TB 

  • Serial Number[Deleted]

  • Directly connected to Router (Gigabit)

  • Accessing through local network (not WAN!)

With disconnect, I mean:

  • Webinterface not reachable

  • No access through MyCloud-App or Mac Finder or Linux (Raspi)


- I am able to ping the device

- It is present in the routing table

- the WDMyCloud shows up in the Mac Finder, but I can´t connect to it (not even login).

More facts:

  • Router: Ubee (Model on request)

  • the disconnect happens several times a day

  • It even disconnects during copying etc

  • I don´t feel like I am doing something specific when its disconnecting, but it is in heavy use and I am usually working on it when the device disconnects

  • Led-Color doesn´t change, its Blue when not reachable

Even more facts:

  • ISP is UPC - Cable Internet (Dont know if this matters)

  • Not using TimeMachine or anything at the moment

  • No Antivirus on any of the Workstations

  • Firewall is ok too

  • It makes no difference wether there is a USB-Drive connected or not

If you need more info on the Workstations I am working with or my network setup, please tell me. But in my opinion this is definetly a problem with the MyCloud.

Hi there and welcome to the WD community.

Have you tried resetting the unit ? This is really strange, if you have already tried resetting i recommend contacting support:

Here is a link That might help you with the reset process:

I dont think reseting would help here, as I got the device 5 days ago, and the problem persisted since day 1.

I was thinking about contacting the support, but I can do so not until monday.

having the exact same problem.  I’m considering just putting it back in the box and sending it back.

Talked to the support today, they told me to do a system-reset (as expected). I´m kinda scared because the webGUI says there could be data-loss. 

If this doesn´t help, they consider replacing my MyCloud-Device. When I told them more people are experiencing this problem, they said they will take care of it. :neutral_face:

Try setting a static IP address to the device, out of the DHCP range.

I already did that.

The IP of the drive is and the DHCP-Pool starts at

UPDATE : Talked to the support today again (3rd-time), because the problem was still present after a 40sek reset. They were pretty clueless. So i send them a System Report right after the Disconnecting happend and they are going to look at it tomorrow. :neutral_face:

Just a hunch, the led stays blue even when you’re disconnected. If the nas gets disconnected from the router the led will change other than blue, blinking yellow.

When that happens try immediately check from another node ie. another pc or smart phone.

I’m not aware of your setups but it could be the router dropping the connection as you mentioned heavy usage. Even with a tiny dual core 620mhz cpu and 256mb ram, the nas is able to coupe with several heavy transfers from multiple nodes though bandwidth not guaranteed. 

To isolate, try connecting the nas directly to your pc using static ip via internet sharing.

I dont think the router drops the connection, because I can ping the nas. Also, its stil in his routing table. 

The problem doesn´t only appear under heavy usage. I tried a 40-sek reset today, and then accessed the dashboard. I only tried to create the users again and to some permission-stuff when the nas disconnected itself. (5min after the reset!!)

I will try to connect the nas directly to my pc and see if i can reproduce the problem. But there is no real “countdown” to when the nas disconnects, this could happen after 5min or 6 hours.