My Cloud dead, how to see content on Windows 10?

First, the My Cloud Home Duo is a completely different device than the My Cloud line of devices. It uses a different operating system and has different features and options. There is a separate subforum for the My Cloud Home Duo where people more familiar with that device may be able to assist.

My Cloud Home Duo
https://community.wd.com/c/home-cloud-storage/my-cloud-home-duo/230

Second, for local network access to the My Cloud Home line of devices one should, I assume, be able to use Windows File Explorer or Mac Finder to access the My Cloud Home device (or at last one’s “private user space” on the device) and not have to use MyCloud.com or the WD mobile apps. If one can access the My Cloud Home using Windows File Explorer/Mac Finder then one generally shouldn’t be limited to copying/moving 50 files at a time using local network access.

Third, no idea if one can remove the hard drive(s) from a My Cloud Duo and access them by directly connecting them to a computer. I have never used a My Cloud Home device so I have no experience with them.

My Cloud Home Private User Space and Public Share Access
https://support-en.wd.com/app/answers/detail/a_id/3009

How To Map a WD Network Drive on Windows 10
https://support-en.wd.com/app/answers/detail/a_id/25436

Thanks, I‘ll check that.

Dear friends, i need urgent help. Please.
I have a WD DL2100 that suddenly stopped working. My guess is the ATOM Chip problem. The power button is always blinking blue, i already did all the resets that i know (4 seconds… 40 seconds) … but i had no luck.
My problem is the DATA, i need urgent access to the DATA.
I had 2 HDD on the inside in RAID 1 (mirror).

Can someone please tell me how can i access the data since i was on raid?
thank you!

Also, i should point that WD support is terrible. I already sent several e-mails to wait for an answer for 5-6-7 days… and the answer is something like “do the 40 seconds reset”.
Unreal.

I have Windows / Macbook avaiable. Also i can format and install linux in one machine if needed… i just need to know hows the best way to acesso the data i had on the DL2100 (Raid1)

Many thanks in advance. im desperate.

See the dedicates subforum for the DL Series where users more familiar with that multi bay device may be able to assist. This subform and this topic generally discusses issues related to the single bay/single drive My Cloud. Various things suggested in this subforum and topic to access a single bay My Cloud model on Windows 10 may not work with or on or apply to multi bay My Cloud models.

OS3 (v2.x firmware) My Cloud DL Series
https://community.wd.com/c/network-attached-storage/my-cloud-business-series/154

OS5 (v5.x firmware) My Cloud DL Series
https://community.wd.com/c/os5/my-cloud-dl-series-os5/259

I installed the latest verion of Paragon Linux File System for Windows. The drive I am trying to access is an XFS drive. I know for XFS its read only but for what ever reason explorer shows nothing but a 0KB .reservespace file. Even though explorer and paragon’s software both show that the drive is using 873.08 GB of storage out of 928.42 GB total. I tried unhiding everything and still can’t see anything. Hentman Recovery software can view the files but I don’t want to pay an additional 100 bucks when I already paid the 20 for Paragon’s and per the site it should work. Am i don’t something wrong here? waiting for a response from their technical support.

Do you have a My Cloud device? If so which specific model? What is an “XFS drive”?

This discussion is specifically about trying to access a My Cloud device on Windows 10. Further discussion is about mounting the My Cloud hard drive to read the Linux formatted partitions so a user can recover data from the EXT4 formatted data partition used on the My Cloud hard drive. For any other devices or hard drive formats you should look elsewhere including seeing Paragon support if their product isn’t reading/mounting what ever hard drive (or it’s partition format) you are using.

Hey sorry i didnt explain it better. My drive is a my cloud device but i have said the physical drive out of the enclosure for so long that i cant remember the model. I remember it had the twonky media server if it helps. I purchased the PARAGON LINUX FILE SYSTEM FOR WINDOWS which is the latest version of their software. When i plug the drive in, the software reads 3 partition, 2 are EXT4 file system but thise literally look like they only have system files on it. I can read and write on those two fine. The 3rd partition which has my actual files on it is listed as a XFS file system. But when i open it the only thing i can see is a .reservespace file even though file explorer says 843GB of 928GB is being used. PARAGON’s own site says that EXT4 is read/write with the software and XFS is read only but i cant see anything at all on the 3rd partition. I unhid everything including system files and still nada.

I tried a trial version hetman recovery software and the files on that XFS partition showed up there but i cant move them without purchasing. But i dont want to pay 100 dollars if Paragons software is supposed to do the same thing and i actually paid for the full version of the paragon software. I’m trying to figure out what I’m doing wrong if anything.

The data files on the My Cloud hard drive are stored on the EXT4 partition. If that partition is not present, it is possible it has either been corrupted or has been erased. There are various other ways besides using Paragon’s software to read the EXT4 partition. One option is to use a Linux boot disk/flash drive to boot the computer with. The Linux OS should then mount or be able to access any compatible drive it finds on the attached hard drive. Ubuntu is one popular Linux distro that can be used as a boot disk/boot flash drive.

There are other programs that can be used to read the EXT4 partition on Windows computers. For example:
Ext2Fsd
DiskInternals Linux Reader
Ext2explore

If the My Cloud user data partition has been corrupted or reformatted and is now reading as XFS format then one may have to look into using data recovery programs to see if they can recover the EXT4 partition.

I understand the other methods. My issue is that paragon states on their site that their software can read the XFS file system. It clearly sees the drive and lets me see the .reservespace file but wont let me view anything else. It reads/writes the EXT4 partitions just fine.

I already put in a trouble ticket with paragon and am waiting for their answer. I just reached out here to see if maybe someone was familiar with the software and could point out something that i might have possibly done wrong on my end.

Like i said i read the XFS partition fine with a trial version of Hetman Partition Recovery and the files are all there and in tact, it just wont let me copy the files without upgrading for 100 bucks. The problem is not paying for the new software, the problem is getting the software I already paid for to work as advertised. I was already looking at Disk Internals Linux reader prior to posting here and they also require the paid version to work with XFS.

But have you tried them, particularly using a Linux boot disk/flash drive like Ubuntu? For example, Ubuntu indicates; “XFS is fully supported by all Ubuntu-Versions”. (https://wiki.ubuntu.com/XFS)