My Cloud cannot map or make shortcut

I can see the drive in SmartWare. I can see the MyCloud web access.

Win 10 and a new install at that.

I go to the SmartWare and go over to my drive and hit map network drive. It says it cannot find the path.

In file explorer I see the drive as Network storage and as a device but I cannot see any of the share folders.

This happening on all of my computers in the house.

Frustrated. Please help. TIA

Do you have a My Cloud or a My Cloud Home?

if you have the My Cloud Home install the WD Discovery software and it will automatically map the private user space as a drive when you sign in

I have a MyCloud.

I can ping it and my Sonos plays from it just fine. When I try to map it from explorer it doesn’t see it at all. When I map it from Smartware it can not find the Pathname.

Tried Discovery and it says there is no drive connected.

WD Drive utilities says to “attach a supported WD drive”

But in file explorer (Network tab) I can see the root share but the folder is empty in Computer when clicked.

In Media devices I can see the media share. Twonky opens up when I click it.

In “Storage” I can see it and when I click on it it goes to the web access just fine.

That sounds like a tool for dealing with locally-attached HDDs, not a NAS. And, indeed it is:

“This installer - WD Drive Utilities and WD Security, are contained within the WD Drive Utilities and the WD Security zip files and installs custom Western Digital software for WD USB and FireWire enabled external hard drives under Macintosh computers.”

O.k. I am trying what is suggested because I am at my wits end with this.

WD Discovery is still not finding it though.

WD Discovery is not for the single bay/single drive My Cloud unit(s):

Applicable Products
My Book Duo, My Book, My Passport Ultra, My Passport SSD, My Passport, My Passport for Mac, WD easystore Portable, WD easystore Desktop

For the single bay/single drive My Cloud unit(s) use WD Access:

Applicable Products
My Cloud, WD Cloud, My Cloud Mirror Gen2, My Cloud Mirror, My Cloud PR2100, My Cloud PR4100, My Cloud EX2 Ultra, My Cloud EX2, My Cloud EX4, My Cloud EX2100, My Cloud EX4100, My Cloud DL2100, My Cloud DL4100, My Passport Wireless Pro

Edit to add: Directions for mapping the single bay My Cloud:

1 Like

Access worked. More of a brain fart on my end after the computer swaps. Thanks everyone who helped.