My Cloud Backup for iOS not backing up all files


#1

I have setup My Cloud on my iPhone 6s and enabled auto-backup for photos and videos. The synchronisation seems to work at the start and if i look at the activity it syncs 57 images until it says it has completed. However there are far more than 57 images on my phone and no matter what I do (turn on/turn off) auto sync the app will only sync the most recent 57 images on my phone. There are currently several hundred images that i want to sync across but for some reason it won’t copy all of them. I know that the app need to be left running in the foreground and that the lock screen will prevent it from syncing but i have tried all this and still I am unable to sync all the photos. Any ideas on how to resolve this?


#3

Did you set the iPhone Auto-Lock to Never (lock) in the iPhone settings?


#4

Yes, I tried that but it didn’t make any difference. I even sat and watched the phone to make sure it didn’t lock or lose focus from the application. For some reason it will only sync a small subset of the photos on my phone.


#5

I have just started looking at the ios backup and it talks about how it completed X “items”. However, those do not appear to be files. They appear to be blocks of data. Many are completed and maybe only one file is downloaded when I watch on the NAS (hence guessing they are blocks). It looks like each time the app is started, it upload X blocks of data and stops and says “complete”. So, I have sat for an hour letting it complete, close the app and open so it does another chunk. I also do not see any indication of total files and how many have been transferred. It is a very crude tool.


#6
  1. MC app will only operate correctly from a fresh start of the app; not from a minimized condition.

  2. Always have Auto Lock set to Never before attempting upload.

  3. Create a new folder to upload into if still having trouble.


#7

Thanks for those points, I am aware of it only working once on each open and Never on the Auto Lock. I was just attempting to describe the behavior as I have seen it to try to explain why the app keeps saying complete when it has not downloaded all the photos. I thought that was the question being asked. I believe I have accurately described the application behavior which is not intuitive at all.


#8

Notice my reply was to the OP.


#9

I have figured out why My Cloud backup is only backing up some of the files. When I look at the DCIM folder on my phone it contains multiple image folders called 102APPLE, 103APPLE etc. These folders are created automatically by iOS for storing images. It appears that the My Cloud backup app is only looking at one of these folders. I.e. I can see that all of the files in one of these folders has been backed up but none of the files in the other folder have been backed up. Hopefully WD will address this issue in future updates.