My Cloud App Update 3.1.1 on iOS 7 does not work with Apple Airplay anymore

Hi all,

I updated the “My Cloud” App on my iPhone 5 to the latest version this week.

Before this update it was no problem to select a video in the WD My Cloud App (in the public folder of my WD My Book Live Duo) - playing the video by selecting the file - and after that i switched Airplay on to watch it over AppleTV. I used this with my iPhone and iPad and it worked perfect.

Since the new update (of the App)  the App stops streaming from the WD My Book Live Duo as soon as Airplay is switched on. The Video freezes after a short time because the buffer is empty.

Everything worked perfect before. I tried it with different iOS devices - always the same result :frowning:

Any Idea what this could be? - WD please fix this problem in the App!

Anybody the same problem?

Kind regards



Have you tried unisntall and reinstalling the App?

I have the same problem.

I have My Book Live Duo but I’m not able to see any picture using " My Cloud" app installed on my iPad via AirPlay on Apple TV. When I stream Photos (buil-in app) to apple tv everything is fine until I switched to My Cloud, after that Apple TV back to main menu. 

iPad iOS 7.1.1

My Wd Cloud 3.1.1

Thanks inadvance for help