My Cloud app - unable to copy files from cloud to attached USB

My Cloud Android app - unable to copy files from cloud to attached USB.

External drive is connected and seen in My Cloud App.
I can select (1), or many, files from MyCloud
I select the ‘Copy’ option which takes me to the MyCloud drive selection
I select the attached drive as the destination
The dialog refreshes
I select the ‘check-mark’ to initialize the operation
It appears to start
I select Activity to view status


MyCloud Dashboard shows all connections are valid.
My laptop shows the expected connected MyCloud and the attached USB drive.
I can copy/open files from MyCloud over my network without error.
I cannot collect logs as it errors with a network failure, which with the previous statements of connectivity is a false error.

This worked on Sunday/Monday and then started failing.
I’ve tried multiple USB drives and all are failing. Even ones that worked previously.

No indication as to why.
No way to collect logs.
No way to investigate problem.
No way to troubleshoot problem.

It would be best to contact WD Support about this. You can do so over the phone or via E-mail.

1 Like

I actually did that as well when I posted here.

Their response…re-FORMAT the drive. Not really sure as they were not specific in their response as to the external USB connect rive or the MyCloud drive itself.

Needless to say, I did not reformat anything.

I did however discover a solution.

  1. External drive
    • Reformatted, since it was empty, from laptop
      - Tried connecting after this and still failed
    • Renamed drive ID (the app kept getting hung up after connect/disconnect/reconnect operations)
    • Connected to MyCloud via USB and powered separately
  2. Performed a Reboot of the MyCloud drive from the MyCloud Dashboard
  3. …Wait as it is not a fast process
  4. From MyCloud Dashboard open Settings
  5. Open General
    • Wait for all necessary connection options to initialize
    • Verify the ‘Cloud Access’ -USB Content Accessibility- is active (it was turned OFF at one point for no reason)
  6. Open Network
    • Verify DHCP, SSH & FTP were active (these were turned OFF at one point as well)

After all this operations went back to normal and the app works and can process data.