My cloud app stopped working after update to android 10

My Samsung S5e updated yesterday, and since then the my cloud app no longer works. My phone also uses the app and is still working. Anyone else having a problem? Getting “network connection failure (906)”.

Have you tried uninstalling the My Cloud app on your Samsung device, then reinstalling it? Have you tried removing the association with or link to the My Cloud within the app, and re-adding it?

I did try uninstalling and reinstalling the app. It didnt help. Do i need to be on the same network to re-add the device?

From what I remember you can add the My Cloud while added to the same local network. Or if you are not on the same local network you can, within the My Cloud Android app, manually add the My Cloud using a activation code that is generated via the My Cloud Dashboard > Cloud Access > (select user) > Get Code button.

I removed then re-added the mycloud from the app and dashboard (when i was back on my home network). The app works okay on the home network, but not over the internet. Same problem as before: Network connection failure (906).

The app works just fine on my android 8 phone, but not on my tablet now that it uses android 10. The my cloud app needs a fix for android 10. Are there any WD people on here?

It appears that others are also having this same issue:

Dont be fooled - the last app update changed the error message from “network connection failure, error 906” to “Something went wrong”. Very helpful!

Hello paulj2,

So did you read the solution that helped me?
For me it was not a problem of the app but of the firmware of the mycloud itself!
Download and Install Firmware Version 2.12.127 on the mycloud!

Did you try that?

Thanks for replying. I have a 2tb single drive gen 1 MC which has the latest version 4 firmware. Which MC do you have? Mirror? gen 2?

Open the dashboard in your browser. It will report the installed firmware.
If it is a firmware, it is gen2.
If it is firmware, it is gen1

So i have gen2… Ask WD or look on their downlod site. For me, as i said, this version was NOT shown in the dashboard as a downloadable update!!! I’m pretty sure they have a newer one :joy: f…ing selling strategy for me…

The updates are here WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links

Kinda odd that your version is not listed. Having trouble convincing WD that the MC gen 1 needs an update.

Firmware 2.12.127 is not used on a second generation single bay My Cloud. Instead that firmware appears to be used on the multi bay My Cloud models. What specific My Cloud unit do you have?

The single bay My Cloud models (first and second gen) look like this:

As a general notice to anyone reading this thread, Do not try to use the firmware links in the WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links page on a multi bay My Cloud Model. The firmware in the WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links page is solely for the single bay/single drive My Cloud versions.

I never said its single bay, its a MCmirror. I said WD dashboard did not tell me that there is a newer firmware available.i said to paulj2 to ask WD or go to the download site and look if they show there a newer one.
Paulj2 postet here in this thread a link to the other thread. There everything is written down.that i have a WDmirror and also what the solution was. There you would also have found the downloadsite with a fallout of every model. There you can do also a search for newest firmware for single bay models.
To make it more easy for you, here the link

For me it seems that there are 2 firmwares for single bay MC

Version: Firmware Release 04.05.00-342 (09/04/2019)

And a version:
Version: Firmware Release 2.31.204 (12/16/2019)

So i would say the first link is gen 1 single bay MC and the second is for gen2
But better check that back yourself AND ask WD at FIRST if thats correct

So paul, the question now is, do you have this version 04.05.00-342 on your MC?

You appeared to have introduced confusion with your posts to which it appears even user PaulJ2 had to ask what device you had. To review:

You indicated that the problem was the firmware, and further indicated that the person you replied to download and install firmware 2.12.127, even saying “did you try that?”

User paulj2 asked what device you had.

As a reply, you indicate you have a “gen2”. Typically, in this subforum which typically discusses the single bay My Cloud units, when one says “gen2” they are not referring to a My Cloud Mirror they are typically referring to the second generation single bay My Cloud model that uses v2.x firmware. And even though there are two versions (or generations) of the My Cloud Mirror, it appears both versions use some form of the v2.x firmware. And further it appears this Mirror firmware may not be compatible with the single bay second gen My Cloud based on different firmware numbers used for each firmware versiion release for each of the different My Cloud devices/models.

User paulj2 points out the single bay/single drive My Cloud firmware and says “your version is not listed”. Hence my reply to point out the single bay/single drive My Cloud does not use 2.12.127 and then further asking what you were using.

The apparent confusion is easily evident as indicated…

For user PaulJ2, if it really is a firmware issue, you can try downgrading (assuming you are using the latest version 4.05.00-342) your first gen single bay My Cloud’s v4.x firmware to an earlier version like 04.05.00-334, using one of the downgrade methods mentioned in the WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links link.

And a little bit of history for those confused about the WD firmware versioning for the single bay/single drive My Cloud. WD initially released the single drive My Cloud, P/N number on the bottom of the enclosure, ends with “-00” with firmware 03.00.03-413. As WD updated the firmware, WD eventually decided to move to v4.x (04.00.00-607) around July of 2014 (at one point calling it OS3 to further confuse things). Along the way WD decides to introduce a new single bay model with different hardware and using the v2.x (2.10.302) firmware structure (including Busybox) around October of 2015. The P/N number of this unit ends with “-10”. At the time this created much confusion with people taking to this subforum to complain and question about the firmware version naming. To this day the difference in firmware for the single bay My Cloud model still causes confusion. Then WD went and confused people even more with the My Cloud Home but that is a discussion for a different thread.

I was also having the login issue and connection problem, this is what I did.
1- Go to the admin of my cloud.
2- Enable again cloud access, for some reason this was reset back to no access.
3- Add email address to the accounts
4- uninstall the android app, I even deleted all the files on it.
5- install it back,
6- Login with the email address set on step 3

on WDs advice i disabled upnp in my router. This forces the MC to use a relay connection. This fixed the problem for me.

I have the same problem my a Galaxy S10+ and the app stopped working on 8/21 like it did for many Android users. Spent an entire day with WD support and the end result was that they recommended I use a different device. I would really appreciate it if they would fix the issue so I do not need to buy a new device.

I have contacted the supportteam through chat:

Johnathan A: It seems like we have done all the troubleshooting but still device is not accessible on android app.
Johnathan A: We have to escalate the issue to the senior team so that they could look into the issue.
Johnathan A: I need some mobile details for this
LJchiel: WD knows that i am not the onlyone having this problem?
LJchiel: what do you need to know?
Johnathan A: Please help me with

  • android version
  • mobile brand
    Johnathan A: Yes, lately we are facing some trouble with mobile app so we have to escalate cases to team.

hope they find a solution soon…
maby it helps them to provide information, so contact them trough chat.