My Cloud App on Apple TV- problems- HELP

Not a technical person so bear with my description of the issues but in the last day or so the My Cloud app isn’t working correctly on Apple TV. If you select a video to play, when you click menu - usually takes to back to the thumbnails of video but now takes you out of the app back to the Apple TV menu, you can’t pause or stop a video, fast forward, nothing and then you can’t get back to the thumbnails, you are just stuck. So in order to select another video you basically have to restart the Apple TV, re- sign into the My Cloud and start over again. It treats the menu button as a pause and will hold your spot but you can never see another thumbnail/ make another video selection. I have 2 Apple TV’s and it started on one last night and then by morning the other one was doing it to as well both Apple TV’s are 14.2 iOs. Can anyone advise or is anyone else having this issue?

Is it just me? Or is there a real problem here? Please advise.

Thanks,
Shannon

I’m having the same problem, tried uninstalling and reinstalling the app but still have same issue?

Hey Scott! I just fixed it late last night. I downloaded Plex and linked Plex to my My Cloud Home. Log in to My Cloud Home- under the Do More you can see how to enable Plex, basically you make a new folder called plex, load what you want in there and then through Plex you set up an account (free) and sync them. It took a while but it’s really a slick set up. Good luck! Works great for playback on Apple Tv.

https://help.mycloud.com/mch#How%20do%20I%20configure%20Plex?