My Cloud App (iPhone6) fails to complete auto backup

I have a My Book Live installed on my router and My Cloud installed on my iPhone 6
The My Cloud app is version 4.4.8
I am trying to auto backup my wife’s photos from the My Cloud app
It has 1889 items and just under 20gb of photos
I have run it many many times and it just continues to “fail” without giving me any reason.
There is no pattern to the % complete when it fails.

I have already backed up my iPhone 6 photos of another phone and that went well.
I have tried all of the workarounds that I can find on the web but none are working.
I cannot increase the size of the cache larger because the next option after 20GB is 128GB and there is not that much space available on the phone. It has about 70GB free.

The only message I get is “Failed”

What else can I try to get this app working?


But I have good news

After many more hours of playing around I figured out what the issue was that was causing the failure.

I tried to copy the files into the directory using the …Add Photo tool. What I was hoping was that the files would all copy across and fool the application into believing it had done it through auto backup so at least the auto backup could start properly to add any new photos

But it failed too - BUT doing it this way resulted in the app giving me some clues what it was struggling with

It seems that in the phot collection on the iPhone was a rather long video (.MOV) - about 2.5 GB. That blew me away and I am sure my wife had no idea that something so big was sitting in her iPhone folder. Such is the usefulness of IOS. But it didn’t end there - too me an age to figure out which file it was given that IOS won’t display file names nor file sizes.

Eventually I found it, deleted it, and retried the auto backup. Worked a charm.

I can’t find anywhere where this is documented, and the message suggested it was a setting - but I can’t find a maximum file size setting either

1 Like

Hi there,

Good to know you where able to solve the issue, hopefully other users that have similar issues can see this and solve it.

regarding the size of the backup, i believe there is no way to change the size of the backup from the phone, maybe by increasing the cash size.

I am glad you found the issue at hand, but you answer was in a post in this ecact forum category. Read this:


I am not sure that the post you referred to actually covers the file size
I had already set my iphone to never to make sure it stayed active while
the large update was happening
It was still failing

The solution I found related to the size of files it is transferring.
Within the directory was a huge movie file. I thibk the application fails
at 2GB for any particular file.
If you want to find the limitation try this:

  1. Create a huge movie video on you iphone (eg 5GB)
  2. you try an auto backup now - it will fail but not tell you why.
  3. Open My Cloud on your iphone and navigate to the directory where you
    would like to transfer files to
  4. Use the … button on the top right of the scree and select “Add Photo”
  5. Navigate to the right directory in photos (e.g. camera roll)
  6. Open this - and select all

The application will run until it gets to the 5GB file ten it will fail.
But here it will give you a message to the effect that it has found a file
that is larger than the maximum size (of I think it said 2GB) set. But I
can’t find anwhere where the maximum file size is “set” so it must be
within the app code?


No, my link did not address this; it only addressed “normal” situations – which yours was not. Obviously, the large video resulted in the video accidentally being created. This is an iPhone issue, and likely would not happen in most cases, so I would not expect WD to even mention this issue. Many people had expressed puzzlement of transferring large quantities of files, (including myself) and is why I figured out the problem and solution and posted it for anyone to see.

Thanks for passing on your problem and solution, although I will skip the opportunity to replicate it! :slight_smile: