My Cloud app display missing last file in a folder

Hi everyone, i have a problem for use WD My Cloud app
Device: WD My Cloud 3TB with 512MB Ram
Firmware: 2.30.165

when i use Win7 explorer to access the My Cloud 3TB
actually have 16 files in a folder, something like this
with chinese file name - 01.rmvb
with chinese file name - 02.rmvb
with chinese file name - 03.rmvb
and so on
with chinese file name - 16.rmvb

but when i use My Cloud app to Local access the Cloud device, it display missing last one item, for this case it show only
01.rmvb to 15.rmvb

even scroll bar pull down to the end, still showing 15.rmvb only
but if change the sort order to Z-A
it show 16.rmvb to 02.rmvb, so missing the 01.rmvb

i tired reinstall the app, but no help
can anyone help me to fix this please


Have you tried resetting the unit? If not, please do that as this will help the unit to update the library.

See if this helps

tried 4 sec and 40 sec reset but still no help
the weird things is if i created a empty_no_data.txt file into that folder to make this file display at the end
use My Cloud app it display all 01 - 16.rmvb
ofc missing the file empty_no_data.txt

so the problem not about the Cloud device
is the app problem