My Cloud App 4.4.1: Can't see smartware or timemachine shares

Since upgrading to mycloud 4.4.1 on an iphone and an ipad I can no longer see the smartware or timemachine backup share folders on my MyCloud NAS. Another iPhone still using MyCloud app 4.1.3 has no trouble seeing all the shares, they are still present. MyCloud NAS is running firmware v04.04.00-308. I found one other user in the forum Italiano reporting the same issue, but thought I’d bring it up here in the English community for a larger audience. Has anyone figured out why these folders are missing?


The OS 3 My Cloud App starting with version 4.4.0 does not display the OEM backup shares Time Machine and Smartware. 


Samuel Brown

Could you please advise WHY you have removed Smartware file access via the latest MyCloud app. How do you access files in those folders now? I’ve just spent the last 2 hours trying to work this out! The app worked fine before. Thanks.

Same problem here! How is one supposed to access these files?

I have the same problem…wrote to support via google play market and via wd support, no reply…bad service

In my ipad the 4.1.3 version works correctly but the new version on my iphone doesn’t work.
I have spoken with the WD support and they told to me that there is a server migration: they think that at the end of this migration probably Smartware folder will return into the app.


WD Support will publish a KBA regarding the subject matter, however, here’s an explanation for the change.

  • The Smartware Share’s purpose is to provide a dedicated backup share for WD Smartware Software.
  • The TimeMachineBackup Share’s purpose is to provide a dedicated backup share for Time Machine.

Users that place private data inside of the designated backup shares stand a good chance of corrupting the backups that are written to the shares.  The Backup Shares can be accessed by their backup utilities (Smarware & Time Machine) or using a nework broswer such as Windows Explorer.

User Comment:  But, I do not have Smartware and I so not use TimeMachine for backups. So why won’t WD let me see those shares in the mobile App??

If you feel the need to place your private photos or other content in a share designated for Time Machine and Smartware backups, there is a very simple solution:  “I DO NOT RECOMMEND THIS SOLUTION” however I’m here to provide answers and assistance to the group.

  1. Delete the OEM Smartware and TimeMachineBackup share
  2. Create them again using the same name and they will be private shares viewable from your mobile App

Hope this helps,


Samuel Brown

Thanks for the info, just as an FYI it’s incredibly useful to have remote access to one’s backup share as it essentially gives me remote access to my pc, even if it is turned off / asleep. You never know when you’ll need some random document. Also I tried the above andI it seems you need to change the share name ever so slightly when you recreate it.

Ok. Questions:

  • when you say “delete” and “create again” you mean delete and create the backup or only the smartware share? Because my PC it’s corrupted by a virus now and I want to save my last backup but I 'm not able to create a new one now.
  • If you mean delete and create “only” the Smartware share may I do it from ipad or I need the pc?


Really confused now! I thought that the purpose of the app was to give me remote access to my saved files-as the previous poster has instanced. On my PC I am backing up My documents among others. On the app(version 4.4.1) I can now only see Shared Music, Pictures and Videos.

How do I see my Documents?

I strongly support the need to remotely access the latest and previous versions of a document kept in the Smartware share. It may be reasonable to avoid manual update of these backup contents, but we customers need READ ACCESS to it. The way it works now is for me unacceptable. I wouldn’t have bought this product with such a lack of functionality.

the smart ware was sold to backup the computer, not just the WD software, if I can’t access the smart ware, how does one use the back up, or access it if the main PC fails, I am experiencing that at the moment and the new PC has created a new Mycloud and shareware want to back up all the docs and stuff already reinstalled, it’s all too complicated for a layman

Is incredible that WD solution for this problem is to simple inactivate the access to smartware. Many of your customers use this in situation that need a file from the backup or having access to the data on a mobile device. This was a big plus and now you are removing functionalities. I simple can’t beleive that WD solution for this problem was this. What about read access only? Please think better.

Does WD plan to enable the ability to access files that were backed up in the SmartWare share directory? I believe WD Sync would create two copies of each file (one on and on my 6Tb personal cloud), which is something I do not want to do.

Having MyCloud access TimeMachineBackup and Smartware allows me to have remote access to files in my pc. Same as others people have commented, I cannot now access those on IOS. I do not use these folders for anything else other than the back ups. Please provide remote access to these folders again.
I am now having to use Dropbox to move files to, before travelling.

I am in complete agreement with previous comments. WD appear to have removed significant functionality from the My Cloud app by removing access to smartware share, and greatly reduced it’s usefulness. I hope they can put this right soon. Until they do, there appears to be little point to the app or indeed the WD hardware, may as well just use one of the free cloud services.

1 Like

There is a workaround that I successfully tested with a customer. The workaround consists in using any file explorer that can map a network drive, ES File Explorer for Android in this case. Then you have to map the drive with the public IP address of your network and login as admin or any credentials with access to such folders.

Then you have to map the drive with the public IP address of your network and login as anonymous, as such folders are usually public, or with the credentials for your share.

This is very, very bad, from a security point of-view, surely? If your SmartWare backups are Public, and you’re suggesting they don’t need credentials to access, just the IP address, then doesn’t that mean anyone can login as anonymous and access them…?

There is a workaround that I successfully tested with a customer

Does this ‘customer’ comment mean you’re a WD employee? Or just someone with customers…?

I am sorry, I remember to test with the customer when he was in his local network with the internal IP address. I edited my previous post. So, if you login as admin or any other user with access to such folders, you should have access. Anyway I guess for map a drive without WD2go now you need to map a ftp drive and turn it on the ftp server if I am correct.

I am no more than another user in this forum who works with customers.

Ah: local network access without credentials would be fine: I thought you were suggesting remote access wouldn’t need credentials.

I am no more than another user in this forum who works with customers.

Welcome, fellow traveller!