My Cloud and Uverse, Cannot see Wired Devices

I have a Pace 5268AC Uverse router. I found out the My Cloud does not plug and play to the port on back of the router. The My Cloud would show no Ethernet lights, whereas connected directly to a laptop via Ethernet the Ethernet activity lights worked fine.

I attached a TP-Link switch to connect the My Cloud device to the switch then to the Uverse 5268AC router. Now, My Cloud has steady blue light and is accessible only to wired computers - wireless computers cannot see the My Cloud
device in File Explorer or via URL in the browser.

This is almost like IP isolation. I know each wired and wireless have different IP ranges. Wired computers cannot see wireless computers or devices, and wireless computers cannot see wired computers or devices.

How can I make all computers see each other, wired and wireless? More importantly, how can I make the My Cloud device visible to all computers?


Please note that your question appears to have nothing to do with My Cloud nor the issue being caused by the My Cloud. Rather the problem is with your Pace router. You should review the user manual (if one exists) for your router to see if there is a setting that deals with wireless IP address range or with wireless IP isolation.

Also make sure the wireless devices are NOT connected to the “guest” wireless network which is typically isolated from the main wireless network.

I was hoping to find someone here that experiences the same issue with their My Cloud and with this particular router. I am left to either buy a whole second router, or return My Cloud. I think I’ll be returning it and seeking another storage solution as to not dump more money into the problem.

Have you logged into the Pace router and checked the administration page(s)? Look for something like AP Isolation or Wireless Client Isolation. Or look for in the Wireless settings section and see if you can change the IP address range used by the wireless. May want to also disable the “guest” network if one exists to see if that fixes the issue. It appears some have trouble with that router when their wireless devices connect using the 5ghz band rather than the 2.4ghz band (see this link). When that happens the wireless devices cannot see each other across the two different bands. The solution may be to force the wireless devices to connect to the 2.4ghz band rather than the 5ghz band.

You can try to return the MyCloud if you like, but I don’t think this will fix the problem, which, as Bennor says, appears to be a problem with the router configuration. Mycloud knows nothing about the distinction between wired and wireless access; that’s down to the router.

As for needing a switch between router and MyCloud, that appears to be this problem:

Take a step back and think about it… then proceed with Baby steps…

The NAS device does not have any wireless capabilities, so in a few words, it cannot affect it.
Now, if wireless devices cannot communicate with wired devices, who provides the network for both, Is it one device? Look into that device if yes.
Two devices, one for wired and one for wireless? Look into both devices if yes.
Are wifi devices connected to the wifi routers or only have 3g/4g? Make sure of this as 3g/4g would be Internet access only.

Also compare the IP address of LAN devices vs wifi, see if they belong to the same network.