My Cloud 6TB drive

Experienced a power surge and now able to access my cloud 6TB drive, the light on the drive appears as if the drive is trying to operate, it may flash but returns to what appears to be busy. I tried a different power adaptor then the light turned red, removed the ethernet cable as well, still unable to access the drive, is the drive bricked?

What color is the front LED? When plugged into a router, what color are the two back LED’s? Is the network router operable or operating as normal? Have you tried a different network cable and a different network port on the router?

The front LED looks reddish/orange/white (glowing). When plugged in a router the color on the two back LEDs are green flashing (top) no light (bottom). The network router is normal no other devices are experiencing any issues. Yes, I have tried a different cable and port on the router.

A front red LED indicates some sort of problem with booting the drive. Check the My Cloud User Manual for your model for the specific LED indicator colors.

One could remove the hard drive from the My Cloud enclosure and attached it to a PC running Linux or which has a Linux driver to view the drive contents to see if the drive is damaged. If the drive is undamaged one could then use one of the various unbrick methods for the particular My Cloud model and push the firmware files to the drive and see if that fixes the issue.

Or it could be a hardware issue at which point one would have to contact WD Support to inquire about repair if one desires to repair fried hardware.