My Cloud 4TB NAS Hang

I just brought my My Cliud a week ago…I already did restart twice.

It hang after running for one to two days…PC couldn’t connect it totally. Tried any method; My cloud app, IE/Chrome by typing IP 168.192.0…all not worked.

Windows 8 file history backing up half way… I openned the file history…it showed drive disconnected.

Power off then on to solve this problem.

I may use this NAS for years…I don’t know how many times I need ot restrat it in future. It will be worse if I’m outside and need to access the NAS to get file for customer.

Just few hours after posting the msg…now the NAS became very slow…I think I need restart it again.

I read previous post

Some other users have same problem…My Cloud beome slow or totally not responding. Reboot only can help.

WD product so bad…


As a recommendation, you can try performing a system only restore that wont erase the data on the unit but it will set all the settings on the drive back to factory defaults. 

Please see page 84  of the User manual for instructions on how to do that.

System restore will roll back to previous version of firmware? I read from the forum many users claimed that after upgrading to V4, the My Cloud became very slow.

I never tried V3…when I initially setup My Cloud…it asked me to upgrade to V4 immediately.

Yeah… A system only restore will not change anything to solve your issues here, at least it didn’t do anything for me the last 2 times I tried. It will definitely not bring you back to V3.0.

I’d recommend you search on this forum to find the way to go back to V3.0. Honestly, I tried to, and couldn’t get it done. After having messed up with editing script files, getting stuck, i thought the downgrade worked out well, but after I rebooted I could see it failed. I just grew weary of the whole downgrade thing and I am now staying on V4 waiting for better days.

I saw one user reporting he saw dramatic improvements after a full system restore on V4. I had tried this already and didn’t see any difference. I looks like your mileage will vary, who knows why…

Someone in the forum said V4 slow was because of content scanning. They teach how to avoid scanning…but seem to be many steps to do this.

I checked the UI status…it is correct…the scanning is in progress and I can hear the HD running sound.

I was moving large quantity of files and backing up my PC to the NAS yesterday…it is still scanning now (backup already interruptted…Windows said connection error). I want to see how long time it takes to scan and after that the lagging problem still exist or not. I still lagging, I will try system restore.