My Cloud 4TB doesn't connect

I’ve got a 4TB My Cloud HD approx 3 yrs old. Was initially working and connected, but was put into storage for a couple of years. Tried to use it now, and when going through normal setup, I can’t get the HD connected to the wireless router. I notice that when I power up the HD, that the green ethernet light on the back of the device goes out several seconds after powering up the unit. I called support and they told me to try a different cable. I explained that a different cable does not prove anything as the ethernet light is out. I was told by support that the device is defective. Is this so? Anyone else out there who’s had the same experience? I’ve barely used this unit, and it’s upsetting that I’ve paid over $200 for this unit, and now it’s a paperweight… Any thoughts?

Have you changed ISP in the mean time? Are you now with at&t?

I haven’t changed the ISP as my computer won’t recognize the HD. I’m in Canada, with MTS/Bell

Additionally, when the HD is connected via ethernet cable to the wireless router, I end up with a flashing orange light in the front. I’ve tried the 40 second reboot, and after the initial solid white LED on the front, it immediately goes to flashing orange.

Blinking red LED could be caused by the following (from Page 7 of the UM)