My Cloud 4 TB SLOW Transfer Speeds

I have a brand new Western Digital My Cloud 4 TB external hard drive, connected to my brand new Netgear R6250, which is connected to my brand new Motorola Surfboard 6141. I just performed a speed test and I have 56.94 Mbps down and 12.01 Mbps up. The My Cloud is connected to the router through a Cat 5e ethernet cable, and a Cat 5e ethernet cable connects my Macbook Pro to my router. I have the drive mounted on my network so it’s showing up as a hard drive. All my firmware is updated and the drive appears to be working just fine, other than the speed.

Now that you have all my specs, here is my issue: I keep running speed tests using Lan Speed Test (Lite). I have tried using sample files of 20 MB and 150 MB. Every time, the speed test comes back at around 26 Mbps upload and 289 Mbps download. As far as I understand, these are both drastically beneath what the speeds should be.

Can somebody explain how I can improve my speeds? I’m getting a little frustrated that my drive is working well below the performance that sold me on purchasing the drive to begin with. Any help is GREATLY appreciated.

How are you connected to the NAS?   Via AFP protocol or SMB protocol?

I have tried connecting with both, with the same results.

Like you I setup my gear recently (1 week ago)

PC is windows 8.1 and hardware is like 6 years old  icore 2 @2.4 GHz with gigabit ethernet

Router is Netgear WNDR3700v4

mycloud 3TB

computer to router (1 gigabit) bought a new shileded 1gigabit cable for it

mycloud connected to router.

ISP 60MBs fibre optic cable modem

I mounted the shares in explorer using WD Discovery software.

when testing

I get like average 60MB/s Write

and average 40 MB/s read

What are you using to test?

I use NASTester from here

run it and see what it says ( give it the default 5 iterations)

and file size 1000MB

I can’t use NASTester because I’m on a Mac. I use Lan Speed Test Lite.

Also, this thread can likely be merged with the other one I have in this forum.

Well I bought it, it looks decent and supported.

here are my results using 1GB file and 5 packets

Average Mbps (Mega Bits Per Second): 230 W, 473 R

Average MBps (Mega Bytes Per Second): 28 W, 60 R

and that with 2 other pcs playing online games :slight_smile: (kids :slight_smile: ) and 6 other devices connected to the router (all wireless)


Hi all.

I’m with you ristvedt.

On a MacBook Pro.

Attempting to acheive something over wireless.

(And yes to all the others, I am not daft enough to think that I can acheive super fast speeds over a wireless network - It would however be nice to think that I could acheive speeds to and from the drive that’s plugged into my router that are at least as good as the speeds at which I can access the internet!.. I’m seriously now looking at PogoPlug as an option for network storage.)

So ristvedt I’m on the same problem solving mission as you.

I have no idea if it’s the drive, the router, a firewall somewhere, but that’s why I’m here.

I posted a support request on the 8th.

They say that they aim to respond in a day.

No response yet.

In Summary here’s the issue:

I am getting what seem like very slow access speeds on my new MyCloud drive.
After suspecting that I may be having a problem I used AJA System Test which is reporting consistent write speed of 0.4 Mbs and read of 4.5 Mbs

For info, on the same machine on the same network I’m getting internet speeds of 36.3 Mbs Download and 2.13 Mbs upload (In the UK, on TalkTalk).

As I type I’m running LAN Speed Test to see if it produces a different result to AJA System Test.

Having read some of the replies above I have set it to work with a 1000Mb file.

I won’t be doing that again in a hurry. Five iterations may be recommended but I haven’t got a spare day! :confounded:

If anyone has any suggestions other than “it all works fine for me” , or “you’re stupid to think you can acheive a decent speed over wireless” then they’d be very welcome. If 0.4Mbs is  to be expected then this thing isn’t really the product for me.

Happy Easter




I’m looking for your other thread with which may be merged… which one is it?