My Cloud 3TB inaccessibe, freezes, but blue led is on

I bought a My Cloud 3TB device. It’s connected to a Linksys 6300 router, and succesfully initialized - users, shares are created without problem. I’m using it with Macs. After the setup, i copied 30.000 pictures onto the device, an it’s looks unstable. Many times happened, that the device is not accesible from finder, and not accessible from web browser too. I tried to access the device with it’s name, and with IP adress too. The router can’t see the device, but the béue led is on. After re-plug  the power jack, the device restarting,  works again great, for hours. After hours (various - happened, that the drive freezes after 20 minutes, and happened, that can be onlien for one day), it’s freezes again. Nothing solved the problem, just the plug out-and-in the power jack. 

Previously I read the forum, and set up static IP address outside my router’s DHCP range, and turned off the sleep feature (but i’m afraid about it: if the the drive never sleep, this dramatically drop it’s lifetime, will crash earlier). After it, i turned off all media services - I want to use the device as a NAS, that is reachable throught the internet - doesn’t need any movie streaming fature. These things are not solved the  problem,  the device keeps freezing. 

Can anybody tell any helping advice, how can I stop the device freezing? As it working now - have to restart it 3 or 4 times a day - it’s not good. When it’s works, it’s a very good device - i can reach my content from my computers, and from my iPad too, but this always-need-to-restart thing is flustrating. And, I’m not sure, that my data is safe on a device, that need to power off and power on 3 or 4 times a day.

It looks like your unit is suffering from the infamous “drop from netword” issue. Did you upgrade to the latest firmware?

When you upload a LOT of pictures, the drive can become unresponsive until it has worked through all the indexing, thumbnailing, downsizing it feels it has to do on any image it has… This can take a lot of time, maybe several days.

One thing you can try, is to do a factory system restore (quick one). You can start this from the UI, under Settings > Utilities. This will delete all content on your NAS, so make sure you have a backup.

WD is aware of this issue, which is not pervasive.

Several users report success with various tricks which theoritcally makes more or less sense. You already applied the “static IP address outside of DHCP range” and “turn off sleep”. A user has reported that changing the IP lease cycle time in the router to a very high value improve things. Take this with a grain of sa