My cloud 2 can't connect to Xtreamer prodigy

I’ve been trying and trying again and again.
It just happened one day, all of a sudden my Xtreamer asks for a password/login once I try to enter the WD public folder.
I don’t have any passwords or anything like that and all the system is connected through LAN.
Appreciate your help before I give up.

Try using “guest” as the user, and leaving the password blank. If there’s an option, use lanman v1 protocol.

However, this blog suggests that xtreamer has a known problem with public shares.

xtreamer would not know the difference between a win7 share, and a NAS share. If a public share on windows wont work, then a public share on the NAS probably wont either. I would try giving it the guest username with blank password first though.

Thanks for the fast reply.
Tried the “guest” user name with no password, Login Fail.
Where would this password hide? I have no special pw on my WD cloude and all devices are on the same network, LAN.
The funny thing is that the streamer can reach the files through UPnP, but can’t do the same through Network access.

Any ideas?

guest is a special account and traditionally uses no password.

It looks like Xtreamer does not know how to use public accounts. I would suggest creating a user share instead of a public share with this device.

It used to work for several years and suddenly started requesting pw.
I will try to set a new folder (tried it in the past with no success).
Any special requirements for this folder?

Needs to have a user/pass defined (so not public). Otherwise, not really.