My Cloud install fail

Just got the notification to download and install update.  After several attempts I am still getting the “Failed to install , contact support” message.

Running Windows 7 Pro on Dell Latitude, upgrading from

Anyone else having this same issue?

I just updated both my desktop, Gateway and laptop, Dell Inspiron and I did not have any problems. I have Windows 7 SP1 Home Premium.

I clicked on the _ Download Now _ button and it asked me if I wanted to replace the current folder with the same name and I clicked Yes. After the download completed I started the installation and accepted both the license agreements. Then I clicked on Next and the installation started and completed.

Posted by,
cat0w (USA)

Yes i am having same problem, rang WD advised to reset drive did not work. Have read the internet nothing. Have tried to unistal can’t remove it. This is so bad. Help us solve problems. Please

Update: Well Wd support contacted me tonight and without delay resolved issue. Up and running great when you buy from WD you know problems arrise but they always help. PS israel from WD a Thank you are a Star*.:smiley:

Glad to see it’s not just me… come on WD fix this

I call WD support and was told to call back Tuesday and that level 2 tec spt will address this issue. To bad that others are have the same problem.

Here in Denmark I have the same problem…
Windows 7 Pro, updating from…
Hope it works soon! Last update really did some good things for the NAS! :slight_smile:

Anybody find a solution yet?

I see another post where a moderator says uninstall and reinstall, reluctant to try that in case the reinstall fails

Has anyone gone to the Download center and tried downloading it again and then reinstalling it?

Posted by,
cat0w (USA)

Reply to: Chilax

Would you share what WD told you to do to solve this problem so others that are having the problem can try the same solution?

Posted by,
cat0w (USA)


Redownloding it doesn’t change anything, same file, same issue, anybody else

Chillax, sharing the solution might just help everybody else…seem logical?

Hello all,

As a recommendation, please contact WD Support for further assistance on this case.

WD Support contact info:

Called WD tech spt was refered to level 2 spt. Level 2 spt instructed me to allow access to my computer. I tried to allow access to my computer and their server never granted access. Long story short no luck in getting the software to install or uninstall.

I’m having the same problems.

Tech support should not need access to your PC to solve this problem, that is absolutely ridiculous!

I wish they would just post what needs to be done for those who they have solved the problem for so the rest of us can get on with it and fix this issue.

I even tried uninstalling V. and it won’t even let me do that so I can try a fresh install of the new version. What the **bleep** is going on?

You would think WD would test their software before releasing it. Obviously it is a problem for many users.

My OS is W7 64bit.

Found a solution that worked for me 100%.

Please read 5th post by Reny72 in following thread and give him some positive kudos if the solution also works for you.

this fix worked, thanks.

 Seems there is a problem with the uninstall of the previous version .40 of My cloud.