My brand new Book Essential 1T will not upgrade SmartWare

Hi everyone,

I’ve just bought a My Book Essential 1T and after I turned it on, the driver install started straight away and was successful. I then started SmartWare and filed in the Registration and Security such as the password. Before I even made a backup of anything, I clicked on the software update which took me through the whole firmware and software update procedure. I followed everything to the letter, such as disable password, check that .NET Framework 3.5 was already installed in my portable, unplug power and USB after the firmware install and then reboot after the software install. I have completed this process two times (an exhausting one I must say) and I cannot get the software to upgrade. The version that still shows is the (the initial one at startup) and the one downloaded from WD’s site is It just keeps showing the 1.2.020 on the right-bottom corner of SmartWare. I suppose that the firmware went ok because it shows 1.20 and something else that it does not show…on the download the version is 2.010( I’ve spent 2 hours in this process and it just should not be this way…feeling a bit frustrated by now. Can you please help?

Thank you.

Did you ever get a reply or resolution?  I just bought a new My Book Essential 2TB external hard drive and it will not allow me to update the firmware.  I checked all the steps like you, but I keep getting an error message:

“Please disconnect all USB devices and connect only the WD drive you want to update; then click Rescan”

Did you have same error message? 

My Book was the only USB device connected and “Rescan” always produced the same error message for me.  I took it back to store and exchanged it for another one and the second one did the exact same thing.

I am having exactly the same problem with two brand new 500G drives.  I have tried using two different computers (one with Vista, and the other with Windows 7), booting into safe mode, and everything else that I can think of.  So far, I have wasted a lot of time, but I haven’t made much progress.